CVE-2024-40898 Apache HTTP Server: SSRF with mod_rewrite in server/vhost context on Windows

Critical 9.1 Published Updated

An attacker can exploit Server-Side Request Forgery in Apache HTTP Server on Windows to leak NTLM hashes to a malicious server.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-40898?

CVE-2024-40898 is a critical server-side request forgery vulnerability in Apache Http Server, published on 18 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

SSRF in Apache HTTP Server on Windows with mod_rewrite in server/vhost context, allows to potentially leak NTML hashes to a malicious server via SSRF and malicious requests.

Users are recommended to upgrade to version 2.4.62 which fixes this issue.

Weakness: CWE-918

Which versions are affected by CVE-2024-40898?

1 open source package ship an affected version, including apache. It affects 1 product.

PackageAffectedFixed in
apache BitnamiFrom 2.4.02.4.62

Products include Apache Http Server.

How do I fix CVE-2024-40898?

Upgrade apache to 2.4.62 or later.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2024-40898 being exploited?

There is no known exploitation of CVE-2024-40898 in the wild and no public exploit code.

Public exploit code: 2 proofs of concept on GitHub.

All Apache Http Server vulnerabilities

Sources

Also known as ALPINE-CVE-2024-40898, BIT-apache-2024-40898, CLEANSTART-2026-FU14728, GHSA-f6mg-hq7f-jw2j.

Is CVE-2024-40898 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free