# CVE-2024-40898: Apache HTTP Server: SSRF with mod_rewrite in server/vhost context on Windows

> An attacker can exploit Server-Side Request Forgery in Apache HTTP Server on Windows to leak NTLM hashes to a malicious server.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jul 2024
- **Updated:** 13 Sep 2024
- **Also known as:** ALPINE-CVE-2024-40898, BIT-apache-2024-40898, CLEANSTART-2026-FU14728, GHSA-f6mg-hq7f-jw2j

## What is CVE-2024-40898?

CVE-2024-40898 is a critical server-side request forgery vulnerability in Apache Http Server, published on 18 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SSRF in Apache HTTP Server on Windows with mod_rewrite in server/vhost context, allows to potentially leak NTML hashes to a malicious server via SSRF and malicious requests.

Users are recommended to upgrade to version 2.4.62 which fixes this issue.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2024-40898?

1 open source package ship an affected version, including apache. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | From 2.4.0 | 2.4.62 |

Products: Apache Http Server.

## How do I fix CVE-2024-40898?

Upgrade apache to 2.4.62 or later.

## Is CVE-2024-40898 being exploited?

There is no known exploitation of CVE-2024-40898 in the wild and no public exploit code.

Public exploit code:

- This Python script is a Proof-of-Concept (PoC) scanner for detecting the vulnerability CVE-2024-40898, which affects Apache HTTP Server’s SSL certificate validation.   (github_poc): https://github.com/ForceEA001/CVE-2024-40898-SSL-Bypass-Detection
- This Python script checks for the presence of CVE-2024-40898, a critical vulnerability in Apache HTTP Server that may allow SSL/TLS certificate verification bypass under certain misconfigurations.  It initiates an SSL connection to the target server and sends a HEAD request. (github_poc): https://github.com/anilpatel199n/CVE-2024-40898

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-40898 and fix it if it is affected.

What it is: CVE-2024-40898 is a critical server-side request forgery vulnerability in Apache Http Server, published on 18 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-40898 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache (Bitnami): affected from 2.4.0; fixed in 2.4.62

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-40898/ (Markdown: https://insights.sbomify.com/CVE-2024-40898/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-40898
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-40898
- OSV: https://osv.dev/vulnerability/CVE-2024-40898

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-40898/
Summaries are generated and may contain mistakes; the official description above is the record.
