# CVE-2024-41107: Apache CloudStack: SAML Signature Exclusion

> Attackers can bypass SAML authentication in Apache CloudStack by submitting unsigned responses, leading to account takeover if SAML is enabled.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Jul 2024
- **Updated:** 19 Mar 2025
- **Also known as:** GHSA-gmm6-5xx7-57r6

## What is CVE-2024-41107?

CVE-2024-41107 is a high-severity authentication bypass vulnerability in Apache Cloudstack, published on 19 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The CloudStack SAML authentication (disabled by default) does not enforce signature check. In CloudStack environments where SAML authentication is enabled, an attacker that initiates CloudStack SAML single sign-on authentication can bypass SAML authentication by submitting a spoofed SAML response with no signature and known or guessed username and other user details of a SAML-enabled CloudStack user-account. In such environments, this can result in a complete compromise of the resources owned and/or accessible by a SAML enabled user-account.

Affected users are recommended to disable the SAML authentication plugin by setting the "saml2.enabled" global setting to "false", or upgrade to version 4.18.2.2, 4.19.1.0 or later, which addresses this issue.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2024-41107?

It affects 1 product.


Products: Apache Cloudstack.

## How do I fix CVE-2024-41107?

No fix has been published for CVE-2024-41107 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-41107 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-41107 exists.

Public exploit code:

- This repository contains an PoC for the critical vulnerability identified as CVE-2024-41107 in Apache CloudStack (github_poc): https://github.com/d0rb/CVE-2024-41107
- Apache CloudStack - SAML Signature Exclusion (nuclei): http/cves/2024/CVE-2024-41107.yaml

## Other vulnerabilities in Apache Cloudstack

- [CVE-2012-4501](https://insights.sbomify.com/CVE-2012-4501/): Missing authorization in n/a (critical 10.0)
- [CVE-2024-38346](https://insights.sbomify.com/CVE-2024-38346/): Apache CloudStack: Unauthenticated cluster service port leads to remote execution (critical 9.8)
- [CVE-2024-39864](https://insights.sbomify.com/CVE-2024-39864/): Apache CloudStack: Integration API service uses dynamic port when disabled (critical 9.8)
- [CVE-2024-29006](https://insights.sbomify.com/CVE-2024-29006/): Apache CloudStack: x-forwarded-for HTTP header parsed by default (critical 9.8)
- [CVE-2022-35741](https://insights.sbomify.com/CVE-2022-35741/): Apache CloudStack SAML Single Sign-On XXE (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-41107 and fix it if it is affected.

What it is: CVE-2024-41107 is a high-severity authentication bypass vulnerability in Apache Cloudstack, published on 19 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-41107 exists.

Affected product: Apache Cloudstack. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-41107/ (Markdown: https://insights.sbomify.com/CVE-2024-41107/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-41107
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-41107
- OSV: https://osv.dev/vulnerability/CVE-2024-41107

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-41107/
Summaries are generated and may contain mistakes; the official description above is the record.
