CVE-2024-41109 Pimcore vulnerable to disclosure of system and database information behind /admin firewall

Medium 6.3 Published Updated

Authenticated users can access system and database statistics via the admin interface, exposing sensitive configuration details.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-41109?

CVE-2024-41109 is a medium-severity vulnerability in pimcore admin-ui-classic-bundle, published on 30 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Pimcore's Admin Classic Bundle provides a backend user interface for Pimcore. Navigating to `/admin/index/statistics` with a logged in Pimcore user exposes information about the Pimcore installation, PHP version, MYSQL version, installed bundles and all database tables and their row count in the system. This vulnerability is fixed in 1.5.2, 1.4.6, and 1.3.10.

Weakness: CWE-200

Which versions are affected by CVE-2024-41109?

2 open source packages ship an affected version, including pimcore/admin-ui-classic-bundle. It affects 1 product.

PackageAffectedFixed in
pimcore/admin-ui-classic-bundle PackagistAll versions1.5.2
pimcore/admin-ui-classic-bundle PackagistAll versions1.5.2

Products include Pimcore Admin Classic Bundle.

How do I fix CVE-2024-41109?

Upgrade pimcore/admin-ui-classic-bundle to 1.5.2 or later.

Is CVE-2024-41109 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-41109 exists.

Sources

Also known as GHSA-fx6j-9pp6-ph36.

Is CVE-2024-41109 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free