# CVE-2024-41111: BishopFox Sliver Authenticated Remote Code Execution

> A low-privileged operator can execute arbitrary code as root on the Sliver teamserver, compromising the entire infrastructure.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-hc5w-gxxr-w8x8, GO-2024-2993

## What is CVE-2024-41111?

CVE-2024-41111 is a high-severity code injection vulnerability in BishopFox sliver, published on 18 Jul 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Sliver is an open source cross-platform adversary emulation/red team framework, it can be used by organizations of all sizes to perform security testing. Sliver version 1.6.0 (prerelease) is vulnerable to RCE on the teamserver by a low-privileged "operator" user. The RCE is as the system root user. The exploit is pretty fun as we make the Sliver server pwn itself. As described in a past issue (#65), "there is a clear security boundary between the operator and server, an operator should not inherently be able to run commands or code on the server." An operator who exploited this vulnerability would be able to view all console logs, kick all other operators, view and modify files stored on the server, and ultimately delete the server. This issue has not yet be addressed but is expected to be resolved before the full release of version 1.6.0. Users of the 1.6.0 prerelease should avoid using Silver in production.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2024-41111?

3 open source packages ship an affected version, including github.com/bishopfox/sliver.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/bishopfox/sliver` | Go | From 1.5.40 | None |
| `github.com/bishopfox/sliver` | Go | From 1.5.40 | 1.6.0 |
| `github.com/bishopfox/sliver` | Go | From 1.5.40 | 1.6.0 |

## How do I fix CVE-2024-41111?

Upgrade github.com/bishopfox/sliver to 1.6.0 or later.

## Is CVE-2024-41111 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-41111 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-41111 and fix it if it is affected.

What it is: CVE-2024-41111 is a high-severity code injection vulnerability in BishopFox sliver, published on 18 Jul 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-41111 exists.

Affected packages and fixed versions:
- github.com/bishopfox/sliver (Go): affected from 1.5.40; no fix listed
- github.com/bishopfox/sliver (Go): affected from 1.5.40; fixed in 1.6.0
- github.com/bishopfox/sliver (Go): affected from 1.5.40; fixed in 1.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-41111/ (Markdown: https://insights.sbomify.com/CVE-2024-41111/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-41111
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-41111
- OSV: https://osv.dev/vulnerability/CVE-2024-41111

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-41111/
Summaries are generated and may contain mistakes; the official description above is the record.
