# CVE-2024-41121: Custom workspace allow to overwrite plugin entrypoint executable in Woodpecker

> Attackers can overwrite plugin entrypoints in Woodpecker CI/CD to execute arbitrary code on agents or steal secrets.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-xw35-rrcp-g7xm, GO-2024-2999

## What is CVE-2024-41121?

CVE-2024-41121 is a high-severity code injection vulnerability in woodpecker-ci woodpecker, published on 19 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Woodpecker is a simple yet powerful CI/CD engine with great extensibility. The server allow to create any user who can trigger a pipeline run malicious workflows: 1. Those workflows can either lead to a host takeover that runs the agent executing the workflow. 2. Or allow to extract the secrets who would be normally provided to the plugins who's entrypoint are overwritten. This issue has been addressed in release version 2.7.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2024-41121?

6 open source packages ship an affected version, including go.woodpecker-ci.org/woodpecker and go.woodpecker-ci.org/woodpecker/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `go.woodpecker-ci.org/woodpecker` | Go | All versions | None |
| `go.woodpecker-ci.org/woodpecker` | Go | All versions | 2.7.0 |
| `go.woodpecker-ci.org/woodpecker` | Go | All versions | 2.7.0 |
| `go.woodpecker-ci.org/woodpecker/v2` | Go | All versions | 2.7.0 |
| `go.woodpecker-ci.org/woodpecker/v2` | Go | All versions | 2.7.0 |
| `go.woodpecker-ci.org/woodpecker/v2` | Go | All versions | 2.7.0 |

Products: Woodpecker-Ci Woodpecker.

## How do I fix CVE-2024-41121?

Upgrade go.woodpecker-ci.org/woodpecker to 2.7.0 or later.

## Is CVE-2024-41121 being exploited?

There is no known exploitation of CVE-2024-41121 in the wild and no public exploit code.

## Other vulnerabilities in woodpecker-ci woodpecker

- [CVE-2023-40034](https://insights.sbomify.com/CVE-2023-40034/): Repositoty takeover in woodpecker-ci (high 8.1)
- [CVE-2024-41122](https://insights.sbomify.com/CVE-2024-41122/): Custom environment variables allow to alter execution flow of plugins in Woodpecker (high 7.5)
- [CVE-2022-29947](https://insights.sbomify.com/CVE-2022-29947/): Woodpecker allows cross-site scripting (XSS) via build logs (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-41121 and fix it if it is affected.

What it is: CVE-2024-41121 is a high-severity code injection vulnerability in woodpecker-ci woodpecker, published on 19 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-41121 in the wild and no public exploit code.

Affected packages and fixed versions:
- go.woodpecker-ci.org/woodpecker (Go): affected all versions; no fix listed
- go.woodpecker-ci.org/woodpecker (Go): affected all versions; fixed in 2.7.0
- go.woodpecker-ci.org/woodpecker (Go): affected all versions; fixed in 2.7.0
- go.woodpecker-ci.org/woodpecker/v2 (Go): affected all versions; fixed in 2.7.0
- go.woodpecker-ci.org/woodpecker/v2 (Go): affected all versions; fixed in 2.7.0
- go.woodpecker-ci.org/woodpecker/v2 (Go): affected all versions; fixed in 2.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-41121/ (Markdown: https://insights.sbomify.com/CVE-2024-41121/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-41121
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-41121
- OSV: https://osv.dev/vulnerability/CVE-2024-41121

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-41121/
Summaries are generated and may contain mistakes; the official description above is the record.
