{"answers":{"affected":"3 open source packages ship an affected version, including puncia.","exploited":"There is no known exploitation of CVE-2024-41124 in the wild and no public exploit code.","fix":"Upgrade puncia to 0.21 or later.","what":"CVE-2024-41124 is a medium-severity vulnerability in ARPSyndicate puncia, published on 19 Jul 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-41124 and fix it if it is affected.\n\nWhat it is: CVE-2024-41124 is a medium-severity vulnerability in ARPSyndicate puncia, published on 19 Jul 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-41124 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- puncia (PyPI): affected all versions; fixed in 0.21\n- puncia (PyPI): affected all versions; fixed in 0.21\n- puncia (PyPI): affected all versions; fixed in 0.21\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-41124/ (Markdown: https://insights.sbomify.com/CVE-2024-41124/index.md)","id":"CVE-2024-41124","markdown":"https://insights.sbomify.com/CVE-2024-41124/index.md","name":"CVE-2024-41124","record":{"aliases":["GHSA-rwcj-7jjp-4w38","PYSEC-2026-1809"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"CLI utility","requires_auth":"high_privilege","summary":"Attackers can intercept sensitive data or modify traffic because the CLI uses unencrypted HTTP for API communication.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:A/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-319","name":"Cleartext Transmission of Sensitive Information"},{"id":"CWE-311","name":"Missing Encryption of Sensitive Data"}],"description":"Puncia is the Official CLI utility for Subdomain Center \u0026 Exploit Observer. `API_URLS` is utilizing HTTP instead of HTTPS for communication that can lead to issues like Eavesdropping, Data Tampering, Unauthorized Data Access \u0026 MITM Attacks. This issue has been addressed in release version 0.21 by using https rather than http connections. All users are advised to upgrade. There is no known workarounds for this vulnerability.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Puncia Cleartext Transmission of Sensitive Information via HTTP urls in `API_URLS`","id":"CVE-2024-41124","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"information_disclosure","year":"2024"},"n_packages":3,"n_references":3,"next":{"headline":"Out-of-bounds read in SNMP when decoding a string in Contiki-NG","id":"CVE-2024-41125"},"packages":[{"ecosystem":"PyPI","fixed":["0.21"],"introduced":["0"],"last_affected":[],"package":"puncia","purl":null,"source":"GHSA-rwcj-7jjp-4w38"},{"ecosystem":"PyPI","fixed":["0.21"],"introduced":["0"],"last_affected":[],"package":"puncia","purl":"pkg:pypi/puncia","source":"GHSA-rwcj-7jjp-4w38"},{"ecosystem":"PyPI","fixed":["0.21"],"introduced":["0"],"last_affected":[],"package":"puncia","purl":"pkg:pypi/puncia","source":"PYSEC-2026-1809"}],"prev":{"headline":"REXML DoS vulnerability","id":"CVE-2024-41123"},"products":["puncia"],"published":"2024-07-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["ARPSyndicate"]},"summary":"Attackers can intercept sensitive data or modify traffic because the CLI uses unencrypted HTTP for API communication.","url":"https://insights.sbomify.com/CVE-2024-41124/"}