# CVE-2024-41124: Puncia Cleartext Transmission of Sensitive Information via HTTP urls in `API_URLS`

> Attackers can intercept sensitive data or modify traffic because the CLI uses unencrypted HTTP for API communication.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:A/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-rwcj-7jjp-4w38, PYSEC-2026-1809

## What is CVE-2024-41124?

CVE-2024-41124 is a medium-severity vulnerability in ARPSyndicate puncia, published on 19 Jul 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Puncia is the Official CLI utility for Subdomain Center & Exploit Observer. `API_URLS` is utilizing HTTP instead of HTTPS for communication that can lead to issues like Eavesdropping, Data Tampering, Unauthorized Data Access & MITM Attacks. This issue has been addressed in release version 0.21 by using https rather than http connections. All users are advised to upgrade. There is no known workarounds for this vulnerability.

Weakness: CWE-319 (Cleartext Transmission of Sensitive Information), CWE-311 (Missing Encryption of Sensitive Data)

## Which versions are affected by CVE-2024-41124?

3 open source packages ship an affected version, including puncia.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `puncia` | PyPI | All versions | 0.21 |
| `puncia` | PyPI | All versions | 0.21 |
| `puncia` | PyPI | All versions | 0.21 |

## How do I fix CVE-2024-41124?

Upgrade puncia to 0.21 or later.

## Is CVE-2024-41124 being exploited?

There is no known exploitation of CVE-2024-41124 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-41124 and fix it if it is affected.

What it is: CVE-2024-41124 is a medium-severity vulnerability in ARPSyndicate puncia, published on 19 Jul 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-41124 in the wild and no public exploit code.

Affected packages and fixed versions:
- puncia (PyPI): affected all versions; fixed in 0.21
- puncia (PyPI): affected all versions; fixed in 0.21
- puncia (PyPI): affected all versions; fixed in 0.21

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-41124/ (Markdown: https://insights.sbomify.com/CVE-2024-41124/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-41124
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-41124
- OSV: https://osv.dev/vulnerability/CVE-2024-41124

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-41124/
Summaries are generated and may contain mistakes; the official description above is the record.
