# CVE-2024-41129: The ops library leaks secrets if `subprocess.CalledProcessError` happens with a `secret-*` CLI command

> The ops library leaks secrets in error logs when subprocess errors occur during secret CLI commands, affecting Juju charms.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-hcmv-jmqh-fjgm, PYSEC-2026-1753

## What is CVE-2024-41129?

CVE-2024-41129 is a medium-severity vulnerability in canonical operator, published on 22 Jul 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The ops library is a Python framework for developing and testing Kubernetes and machine charms. The issue here is that ops passes the secret content as one of the args via CLI. This issue may affect any of the charms that are using: Juju (>=3.0), Juju secrets and not correctly capturing and processing `subprocess.CalledProcessError`. This vulnerability is fixed in 2.15.0.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2024-41129?

3 open source packages ship an affected version, including ops.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ops` | PyPI | From 2.0.0 | 2.15.0 |
| `ops` | PyPI | From 2.0.0 | 2.15.0 |
| `ops` | PyPI | From 2.0.0 | 2.15.0 |

## How do I fix CVE-2024-41129?

Upgrade ops to 2.15.0 or later.

## Is CVE-2024-41129 being exploited?

There is no known exploitation of CVE-2024-41129 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-41129 and fix it if it is affected.

What it is: CVE-2024-41129 is a medium-severity vulnerability in canonical operator, published on 22 Jul 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-41129 in the wild and no public exploit code.

Affected packages and fixed versions:
- ops (PyPI): affected from 2.0.0; fixed in 2.15.0
- ops (PyPI): affected from 2.0.0; fixed in 2.15.0
- ops (PyPI): affected from 2.0.0; fixed in 2.15.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-41129/ (Markdown: https://insights.sbomify.com/CVE-2024-41129/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-41129
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-41129
- OSV: https://osv.dev/vulnerability/CVE-2024-41129

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-41129/
Summaries are generated and may contain mistakes; the official description above is the record.
