CVE-2024-41144 Malicious remote can create/update/delete arbitrary posts in arbitrary channels
A malicious remote user can create, update, or delete arbitrary posts in any channel when shared channels are enabled, compromising data integrity and confidentiality.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-41144?
CVE-2024-41144 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 1 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Mattermost versions 9.9.x <= 9.9.0, 9.5.x <= 9.5.6, 9.7.x <= 9.7.5, 9.8.x <= 9.8.1 fail to properly validate synced posts, when shared channels are enabled, which allows a malicious remote to create/update/delete arbitrary posts in arbitrary channels
Weakness: CWE-284
Which versions are affected by CVE-2024-41144?
17 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, mattermost and github.com/mattermost/mattermost. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20240619142046-8181a9ddffc0 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20240619142046-8181a9ddffc0 |
github.com/mattermost/mattermost/server/v8 Go | From 9.5.0 | 9.5.7 |
github.com/mattermost/mattermost/server/v8 Go | From 9.5.0 | 9.5.7 |
github.com/mattermost/mattermost/server/v8 Go | From 9.7.0 | 9.7.6 |
11 more packages
github.com/mattermost/mattermost/server/v8 Go | From 9.7.0 | 9.7.6 |
github.com/mattermost/mattermost/server/v8 Go | From 9.8.0 | 9.8.2 |
github.com/mattermost/mattermost/server/v8 Go | From 9.8.0 | 9.8.2 |
github.com/mattermost/mattermost/server/v8 Go | From 9.9.0 | 9.9.1 |
github.com/mattermost/mattermost/server/v8 Go | From 9.9.0 | 9.9.1 |
mattermost Bitnami | From 9.5.0 to 9.9.0 | 9.5.7, 9.7.6, 9.8.2 |
github.com/mattermost/mattermost Go | All versions | 5.3.2-0.20240619142046-8181a9ddffc0 |
github.com/mattermost/mattermost Go | All versions | 5.3.2-0.20240619142046-8181a9ddffc0 |
github.com/mattermost/mattermost-server Go | From 9.5.0+incompatible | 9.5.7+incompatible, 9.7.6+incompatible, 9.8.2+incompatible, 9.9.1+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2024-41144?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20240619142046-8181a9ddffc0, 9.5.7, 9.7.6 or 9.8.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-41144 being exploited?
There is no known exploitation of CVE-2024-41144 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as BIT-mattermost-2024-41144, GHSA-vg67-chm7-8m3j, GO-2024-3023.