CVE-2024-41169 Apache Zeppelin: raft directory listing and file read

High 7.5 Published Updated

Unauthenticated attackers can access server resources, including directories and files, via the raft server protocol in Apache Zeppelin.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-41169?

CVE-2024-41169 is a high-severity vulnerability in Apache Zeppelin, published on 12 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The attacker can use the raft server protocol in an unauthenticated way. The attacker can see the server's resources, including directories and files.

This issue affects Apache Zeppelin: from 0.10.1 up to 0.12.0.

Users are recommended to upgrade to version 0.12.0, which fixes the issue by removing the Cluster Interpreter.

Weakness: CWE-664

Which versions are affected by CVE-2024-41169?

4 open source packages ship an affected version, including org.apache.zeppelin:zeppelin-interpreter and org.apache.zeppelin:zeppelin-server. It affects 1 product.

PackageAffectedFixed in
org.apache.zeppelin:zeppelin-interpreter MavenFrom 0.10.10.12.0
org.apache.zeppelin:zeppelin-interpreter MavenFrom 0.10.10.12.0
org.apache.zeppelin:zeppelin-server MavenFrom 0.10.10.12.0
org.apache.zeppelin:zeppelin-server MavenFrom 0.10.10.12.0

Products include Apache Zeppelin.

How do I fix CVE-2024-41169?

Upgrade org.apache.zeppelin:zeppelin-interpreter to 0.12.0 or later.

Is CVE-2024-41169 being exploited?

There is no known exploitation of CVE-2024-41169 in the wild and no public exploit code.

Sources

Also known as GHSA-7pgf-ppxw-8624.

Is CVE-2024-41169 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free