{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.zeppelin:zeppelin-web. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-41177 in the wild and no public exploit code.","fix":"Upgrade org.apache.zeppelin:zeppelin-web to 0.12.0 or later.","what":"CVE-2024-41177 is a medium-severity cross-site scripting vulnerability in Apache Zeppelin, published on 3 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-41177 and fix it if it is affected.\n\nWhat it is: CVE-2024-41177 is a medium-severity cross-site scripting vulnerability in Apache Zeppelin, published on 3 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-41177 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.zeppelin:zeppelin-web (Maven): affected all versions; fixed in 0.12.0\n- org.apache.zeppelin:zeppelin-web (Maven): affected all versions; fixed in 0.12.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-41177/ (Markdown: https://insights.sbomify.com/CVE-2024-41177/index.md)","id":"CVE-2024-41177","markdown":"https://insights.sbomify.com/CVE-2024-41177/index.md","name":"CVE-2024-41177","record":{"aliases":["GHSA-p288-459w-jxj6"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Zeppelin","requires_auth":"none","summary":"An attacker can execute arbitrary scripts in the Helium module via incomplete blacklist filtering, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"zeppelin","vendor":"apache"}],"cvss":{"score":6.1,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Incomplete Blacklist to Cross-Site Scripting vulnerability in Apache Zeppelin.\n\nThis issue affects Apache Zeppelin: before 0.12.0.\n\nUsers are recommended to upgrade to version 0.12.0, which fixes the issue.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Zeppelin: XSS in the Helium module","id":"CVE-2024-41177","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":3,"next":{"headline":"Apache Arrow Rust Object Store: AWS WebIdentityToken exposure in log files","id":"CVE-2024-41178"},"packages":[{"ecosystem":"Maven","fixed":["0.12.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.zeppelin:zeppelin-web","purl":null,"source":"GHSA-p288-459w-jxj6"},{"ecosystem":"Maven","fixed":["0.12.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.zeppelin:zeppelin-web","purl":"pkg:maven/org.apache.zeppelin/zeppelin-web","source":"GHSA-p288-459w-jxj6"}],"prev":{"headline":"Beckhoff: Local Denial of Service issue in package MDP included in TwinCAT/BSD","id":"CVE-2024-41176"},"products":["Apache Zeppelin"],"published":"2025-08-03","related":[{"cvss_score":9.8,"headline":"Apache Zeppelin: Remote code execution by adding malicious JDBC connection string","id":"CVE-2024-31864","kev_date_added":null,"published":"2024-04-09"},{"cvss_score":9.8,"headline":"Apache Zeppelin: Interpreter download command does not escape malicious code injection","id":"CVE-2024-31866","kev_date_added":null,"published":"2024-04-09"},{"cvss_score":9.8,"headline":"bash command injection in spark interpreter","id":"CVE-2019-10095","kev_date_added":null,"published":"2021-09-02"},{"cvss_score":8.8,"headline":"Improper Authentication in Apache Zeppelin","id":"CVE-2018-1317","kev_date_added":null,"published":"2019-04-23"},{"cvss_score":8.1,"headline":"Session Fixation in Apache Zeppelin","id":"CVE-2017-12619","kev_date_added":null,"published":"2019-04-23"},{"cvss_score":7.5,"headline":"Apache Zeppelin: Command Injection via CSWSH","id":"CVE-2024-51775","kev_date_added":null,"published":"2025-08-03"},{"cvss_score":7.5,"headline":"Apache Zeppelin: Arbitrary file read by adding malicious JDBC connection string","id":"CVE-2024-52279","kev_date_added":null,"published":"2025-08-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["Apache Software Foundation"]},"summary":"An attacker can execute arbitrary scripts in the Helium module via incomplete blacklist filtering, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2024-41177/"}