# CVE-2024-41260: NetBird uses a static initialization vector (IV)

> Attackers with database access can decrypt audit logs to reveal email addresses due to a static initialization vector in the encryption function.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2024
- **Updated:** 15 Dec 2025
- **Also known as:** GHSA-9v35-4xcr-w9ph, GO-2024-3057

## What is CVE-2024-41260?

CVE-2024-41260 is a high-severity vulnerability in n/a, published on 1 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A static initialization vector (IV) in the encrypt function of netbird management's service from v0.23.2 to v0.29.1 allows attackers to obtain sensitive information (email addresses) when in possession of the audit events database.

Weakness: CWE-321 (Use of Hard-coded Cryptographic Key)

## Which versions are affected by CVE-2024-41260?

3 open source packages ship an affected version, including github.com/netbirdio/netbird.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/netbirdio/netbird` | Go | From 0.23.2 | 0.29.2 |
| `github.com/netbirdio/netbird` | Go | From 0.23.2 | 0.29.2 |
| `github.com/netbirdio/netbird` | Go | From 0.23.2 | 0.29.2 |

## How do I fix CVE-2024-41260?

Upgrade github.com/netbirdio/netbird to 0.29.2 or later.

## Is CVE-2024-41260 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-41260 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-41260 and fix it if it is affected.

What it is: CVE-2024-41260 is a high-severity vulnerability in n/a, published on 1 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-41260 exists.

Affected packages and fixed versions:
- github.com/netbirdio/netbird (Go): affected from 0.23.2; fixed in 0.29.2
- github.com/netbirdio/netbird (Go): affected from 0.23.2; fixed in 0.29.2
- github.com/netbirdio/netbird (Go): affected from 0.23.2; fixed in 0.29.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-41260/ (Markdown: https://insights.sbomify.com/CVE-2024-41260/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-41260
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-41260
- OSV: https://osv.dev/vulnerability/CVE-2024-41260

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-41260/
Summaries are generated and may contain mistakes; the official description above is the record.
