{"answers":{"affected":"3 open source packages ship an affected version, including firebase-tools and github.com/firebase/firebase-tools. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-4128 in the wild and no public exploit code.","fix":"Upgrade firebase-tools to 13.6.0 or later.","what":"CVE-2024-4128 is a low-severity vulnerability in firebase-tools, published on 2 May 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-4128 and fix it if it is affected.\n\nWhat it is: CVE-2024-4128 is a low-severity vulnerability in firebase-tools, published on 2 May 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-4128 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- firebase-tools (npm): affected all versions; fixed in 13.6.0\n- firebase-tools (npm): affected all versions; fixed in 13.6.0\n- github.com/firebase/firebase-tools (Go): affected all versions; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-4128/ (Markdown: https://insights.sbomify.com/CVE-2024-4128/index.md)","id":"CVE-2024-4128","markdown":"https://insights.sbomify.com/CVE-2024-4128/index.md","name":"CVE-2024-4128","record":{"aliases":["GHSA-rcm2-22f3-pqv3","GO-2024-2808"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Firebase emulator suite","requires_auth":"low_privilege","summary":"A CSRF vulnerability in the Firebase emulator suite allows malicious websites to exfiltrate local emulator data from developers running the tool.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Google","cpe":[{"product":"firebase_command_line_interface","vendor":"google"}],"cvss":{"score":2.6,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"This vulnerability was a potential CSRF attack. When running the Firebase emulator suite, there is an export endpoint that is used normally to export data from running emulators. If a user was running the emulator and navigated to a malicious website with the exploit on a browser that allowed calls to localhost (ie Chrome before v94), the website could exfiltrate emulator data. We recommend upgrading past version 13.6.0 or commit  068a2b08dc308c7ab4b569617f5fc8821237e3a0 https://github.com/firebase/firebase-tools/commit/068a2b08dc308c7ab4b569617f5fc8821237e3a0","ecosystems":["Go","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CSRF in firebase-tools emulator suite","id":"CVE-2024-4128","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"csrf","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"Authentication bypass in Snow License Manager","id":"CVE-2024-4129"},"packages":[{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":[],"package":"github.com/firebase/firebase-tools","purl":"pkg:golang/github.com/firebase/firebase-tools","source":"GO-2024-2808"},{"ecosystem":"npm","fixed":["13.6.0"],"introduced":["0"],"last_affected":[],"package":"firebase-tools","purl":null,"source":"GHSA-rcm2-22f3-pqv3"},{"ecosystem":"npm","fixed":["13.6.0"],"introduced":["0"],"last_affected":[],"package":"firebase-tools","purl":"pkg:npm/firebase-tools","source":"GHSA-rcm2-22f3-pqv3"}],"prev":{"headline":"Tenda W15E guestWifiRuleRefresh stack-based overflow","id":"CVE-2024-4127"},"products":["firebase-tools"],"published":"2024-05-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-01","vendors":["Firebase"]},"summary":"A CSRF vulnerability in the Firebase emulator suite allows malicious websites to exfiltrate local emulator data from developers running the tool.","url":"https://insights.sbomify.com/CVE-2024-4128/"}