# CVE-2024-4128: CSRF in firebase-tools emulator suite

> A CSRF vulnerability in the Firebase emulator suite allows malicious websites to exfiltrate local emulator data from developers running the tool.

- **Severity:** Low 2.6 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 May 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-rcm2-22f3-pqv3, GO-2024-2808

## What is CVE-2024-4128?

CVE-2024-4128 is a low-severity vulnerability in firebase-tools, published on 2 May 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

This vulnerability was a potential CSRF attack. When running the Firebase emulator suite, there is an export endpoint that is used normally to export data from running emulators. If a user was running the emulator and navigated to a malicious website with the exploit on a browser that allowed calls to localhost (ie Chrome before v94), the website could exfiltrate emulator data. We recommend upgrading past version 13.6.0 or commit  068a2b08dc308c7ab4b569617f5fc8821237e3a0 https://github.com/firebase/firebase-tools/commit/068a2b08dc308c7ab4b569617f5fc8821237e3a0

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2024-4128?

3 open source packages ship an affected version, including firebase-tools and github.com/firebase/firebase-tools. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `firebase-tools` | npm | All versions | 13.6.0 |
| `firebase-tools` | npm | All versions | 13.6.0 |
| `github.com/firebase/firebase-tools` | Go | All versions | None |

Products: Google Firebase Command Line Interface.

## How do I fix CVE-2024-4128?

Upgrade firebase-tools to 13.6.0 or later.

## Is CVE-2024-4128 being exploited?

There is no known exploitation of CVE-2024-4128 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-4128 and fix it if it is affected.

What it is: CVE-2024-4128 is a low-severity vulnerability in firebase-tools, published on 2 May 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-4128 in the wild and no public exploit code.

Affected packages and fixed versions:
- firebase-tools (npm): affected all versions; fixed in 13.6.0
- firebase-tools (npm): affected all versions; fixed in 13.6.0
- github.com/firebase/firebase-tools (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-4128/ (Markdown: https://insights.sbomify.com/CVE-2024-4128/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-4128
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-4128
- OSV: https://osv.dev/vulnerability/CVE-2024-4128

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-4128/
Summaries are generated and may contain mistakes; the official description above is the record.
