{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2024-4140 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2024-4140 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 2 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-4140 and fix it if it is affected.\n\nWhat it is: CVE-2024-4140 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 2 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-4140 in the wild and no public exploit code.\n\nAffected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-4140/ (Markdown: https://insights.sbomify.com/CVE-2024-4140/index.md)","id":"CVE-2024-4140","markdown":"https://insights.sbomify.com/CVE-2024-4140/index.md","name":"CVE-2024-4140","record":{"aliases":["DEBIAN-CVE-2024-4140","GHSA-2rhr-29cm-5chf","MGASA-2024-0198","UBUNTU-CVE-2024-4140","openSUSE-SU-2024:13973-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Perl Email-MIME library","requires_auth":"none","summary":"Attackers can cause denial of service by sending crafted multipart MIME messages to applications using the Email-MIME library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"canonical","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"email-mime","vendor":"rjbs"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"An excessive memory use issue (CWE-770) exists in Email-MIME, before version 1.954, which can cause denial of service when parsing multipart MIME messages. The patch set (from 2020 and 2024) limits excessive depth and the total number of parts.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in Email-MIME","id":"CVE-2024-4140","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"denial_of_service","year":"2024"},"n_packages":1,"n_references":12,"next":{"headline":"Out-of-bounds array write in Xpdf 4.05 due to incorrect bounds check","id":"CVE-2024-4141"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.954.0-1.1"],"introduced":["0"],"last_affected":[],"package":"perl-Email-MIME","purl":"pkg:rpm/opensuse/perl-Email-MIME\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:13973-1"}],"prev":{"headline":"Missing Authorization Checks in SAP S/4 HANA (Manage Bank Statement Reprocessing Rules)","id":"CVE-2024-4139"},"products":["Email-MIME"],"published":"2024-05-02","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["rjbs"]},"summary":"Attackers can cause denial of service by sending crafted multipart MIME messages to applications using the Email-MIME library.","url":"https://insights.sbomify.com/CVE-2024-4140/"}