{"answers":{"affected":"2 open source packages ship an affected version, including tf2-item-format.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-41655 exists.","fix":"Upgrade tf2-item-format to 5.9.14 or later.","what":"CVE-2024-41655 is a high-severity denial of service vulnerability in danocmx node-tf2-item-format, published on 23 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-41655 and fix it if it is affected.\n\nWhat it is: CVE-2024-41655 is a high-severity denial of service vulnerability in danocmx node-tf2-item-format, published on 23 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-41655 exists.\n\nAffected packages and fixed versions:\n- tf2-item-format (npm): affected from 4.2.6; fixed in 5.9.14\n- tf2-item-format (npm): affected from 4.2.6; fixed in 5.9.14\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-41655/ (Markdown: https://insights.sbomify.com/CVE-2024-41655/index.md)","id":"CVE-2024-41655","markdown":"https://insights.sbomify.com/CVE-2024-41655/index.md","name":"CVE-2024-41655","record":{"aliases":["GHSA-8h55-q5qq-p685"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"TF2 item formatting library","requires_auth":"none","summary":"An attacker can cause a denial of service in applications using this library by submitting crafted input that triggers excessive regex processing.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-624","name":"Executable Regular Expression Error"},{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"TF2 Item Format helps users format TF2 items to the community standards. Versions of `tf2-item-format` since at least `4.2.6`  and prior to `5.9.14` are vulnerable to a Regular Expression Denial of Service (ReDoS) attack when parsing crafted user input. This vulnerability can be exploited by an attacker to perform DoS attacks on any service that uses any `tf2-item-format` to parse user input. Version `5.9.14` contains a fix for the issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"TF2 Item Format Regular Expression Denial of Service vulnerability","id":"CVE-2024-41655","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":2,"n_references":3,"next":{"headline":"Sentry vulnerable to stored Cross-Site Scripting (XSS)","id":"CVE-2024-41656"},"packages":[{"ecosystem":"npm","fixed":["5.9.14"],"introduced":["4.2.6"],"last_affected":[],"package":"tf2-item-format","purl":null,"source":"GHSA-8h55-q5qq-p685"},{"ecosystem":"npm","fixed":["5.9.14"],"introduced":["4.2.6"],"last_affected":[],"package":"tf2-item-format","purl":"pkg:npm/tf2-item-format","source":"GHSA-8h55-q5qq-p685"}],"prev":{"headline":"Server-side request forgery in n/a","id":"CVE-2024-41651"},"products":["node-tf2-item-format"],"published":"2024-07-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["danocmx"]},"summary":"An attacker can cause a denial of service in applications using this library by submitting crafted input that triggers excessive regex processing.","url":"https://insights.sbomify.com/CVE-2024-41655/"}