# CVE-2024-41656: Sentry vulnerable to stored Cross-Site Scripting (XSS)

> Attackers can inject malicious scripts via unsanitized integration payloads, affecting self-hosted Sentry users who should upgrade or enforce CSP.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jul 2024
- **Updated:** 13 Aug 2024
- **Also known as:** GHSA-fm88-hc3v-3www, PYSEC-2026-1914

## What is CVE-2024-41656?

CVE-2024-41656 is a high-severity cross-site scripting vulnerability in getsentry sentry, published on 23 Jul 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Sentry is an error tracking and performance monitoring platform. Starting in version 10.0.0 and prior to version 24.7.1, an unsanitized payload sent by an Integration platform integration allows storing arbitrary HTML tags on the Sentry side with the subsequent rendering them on the Issues page. Self-hosted Sentry users may be impacted in case of untrustworthy Integration platform integrations sending external issues from their side to Sentry. A patch has been released in Sentry 24.7.1. For Sentry SaaS customers, no action is needed. This has been patched on July 23, and even prior to the fix, the exploitation was not possible due to the strict Content Security Policy deployed on sentry.io site. For self-hosted users, the maintainers of Sentry strongly recommend upgrading Sentry to the latest version. If it is not possible, one could enable CSP on one's self-hosted installation with `CSP_REPORT_ONLY = False` (enforcing mode). This will mitigate the risk of cross-site scripting.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-41656?

3 open source packages ship an affected version, including sentry. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sentry` | PyPI | From 10.0.0 | 24.7.1 |
| `sentry` | PyPI | From 10.0.0 | 24.7.1 |
| `sentry` | PyPI | From 10.0.0 | 24.7.1 |

Products: Sentry Sentry.

## How do I fix CVE-2024-41656?

Upgrade sentry to 24.7.1 or later.

## Is CVE-2024-41656 being exploited?

There is no known exploitation of CVE-2024-41656 in the wild and no public exploit code.

## Other vulnerabilities in getsentry sentry

- [CVE-2026-42354](https://insights.sbomify.com/CVE-2026-42354/): Sentry: Improper authentication on SAML SSO process allows user identity linking (critical 9.1)
- [CVE-2026-27197](https://insights.sbomify.com/CVE-2026-27197/): Sentry: Improper Authentication on SAML SSO process allows user identity linking (critical 9.1)
- [CVE-2021-47935](https://insights.sbomify.com/CVE-2021-47935/): Sentry 8.2.0 Remote Code Execution via Pickle Deserialization (high 8.7)
- [CVE-2023-39349](https://insights.sbomify.com/CVE-2023-39349/): Sentry vulnerable to privilege escalation via ApiTokensEndpoint (high 8.1)
- [CVE-2023-36826](https://insights.sbomify.com/CVE-2023-36826/): Sentry vulnerable to improper authorization on debug and artifact file downloads (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-41656 and fix it if it is affected.

What it is: CVE-2024-41656 is a high-severity cross-site scripting vulnerability in getsentry sentry, published on 23 Jul 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-41656 in the wild and no public exploit code.

Affected packages and fixed versions:
- sentry (PyPI): affected from 10.0.0; fixed in 24.7.1
- sentry (PyPI): affected from 10.0.0; fixed in 24.7.1
- sentry (PyPI): affected from 10.0.0; fixed in 24.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-41656/ (Markdown: https://insights.sbomify.com/CVE-2024-41656/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-41656
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-41656
- OSV: https://osv.dev/vulnerability/CVE-2024-41656

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-41656/
Summaries are generated and may contain mistakes; the official description above is the record.
