# CVE-2024-41667: OpenAM FreeMarker template injection

> Attackers can execute arbitrary code via FreeMarker template injection in OpenAM's custom login URL configuration, requiring administrative access to set the vulnerable template.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jul 2024
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-7726-43hg-m23v

## What is CVE-2024-41667?

CVE-2024-41667 is a high-severity code injection vulnerability in OpenIdentityPlatform OpenAM, published on 24 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenAM is an open access management solution. In versions 15.0.3 and prior, the `getCustomLoginUrlTemplate` method in RealmOAuth2ProviderSettings.java is vulnerable to template injection due to its usage of user input. Although the developer intended to implement a custom URL for handling login to override the default OpenAM login, they did not restrict the `CustomLoginUrlTemplate`, allowing it to be set freely. Commit fcb8432aa77d5b2e147624fe954cb150c568e0b8 introduces `TemplateClassResolver.SAFER_RESOLVER` to disable the resolution of commonly exploited classes in FreeMarker template injection. As of time of publication, this fix is expected to be part of version 15.0.4.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-41667?

2 open source packages ship an affected version, including org.openidentityplatform.openam:openam-oauth2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.openidentityplatform.openam:openam-oauth2` | Maven | All versions | 15.0.4 |
| `org.openidentityplatform.openam:openam-oauth2` | Maven | All versions | 15.0.4 |

## How do I fix CVE-2024-41667?

Upgrade org.openidentityplatform.openam:openam-oauth2 to 15.0.4 or later.

## Is CVE-2024-41667 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-41667 exists.

Public exploit code:

- OpenAM<=15.0.3 FreeMarker - Template Injection (nuclei): http/cves/2024/CVE-2024-41667.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-41667 and fix it if it is affected.

What it is: CVE-2024-41667 is a high-severity code injection vulnerability in OpenIdentityPlatform OpenAM, published on 24 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-41667 exists.

Affected packages and fixed versions:
- org.openidentityplatform.openam:openam-oauth2 (Maven): affected all versions; fixed in 15.0.4
- org.openidentityplatform.openam:openam-oauth2 (Maven): affected all versions; fixed in 15.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-41667/ (Markdown: https://insights.sbomify.com/CVE-2024-41667/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-41667
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-41667
- OSV: https://osv.dev/vulnerability/CVE-2024-41667

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-41667/
Summaries are generated and may contain mistakes; the official description above is the record.
