{"answers":{"affected":"3 open source packages ship an affected version, including twisted.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-41671 exists.","fix":"Upgrade twisted to 24.7.0rc1 or later.","what":"CVE-2024-41671 is a high-severity vulnerability in twisted, published on 29 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-41671 and fix it if it is affected.\n\nWhat it is: CVE-2024-41671 is a high-severity vulnerability in twisted, published on 29 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-41671 exists.\n\nAffected packages and fixed versions:\n- twisted (PyPI): affected all versions; fixed in 24.7.0rc1\n- twisted (PyPI): affected all versions; fixed in 24.7.0rc1\n- twisted (PyPI): affected all versions; fixed in 24.7.0rc1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-41671/ (Markdown: https://insights.sbomify.com/CVE-2024-41671/index.md)","id":"CVE-2024-41671","markdown":"https://insights.sbomify.com/CVE-2024-41671/index.md","name":"CVE-2024-41671","record":{"aliases":["AZL-47101","AZL-47151","DEBIAN-CVE-2024-41671","GHSA-c8m8-j448-xjx7","PYSEC-2026-1992","UBUNTU-CVE-2024-41671","USN-6988-2","openSUSE-SU-2024:14228-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Python web framework","requires_auth":"none","summary":"Attackers can exploit HTTP request pipelining in Twisted to receive responses out of order, potentially leaking sensitive information from other users.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-444","name":"Inconsistent Interpretation of HTTP Requests"}],"description":"Twisted is an event-based framework for internet applications, supporting Python 3.6+. The HTTP 1.0 and 1.1 server provided by twisted.web could process pipelined HTTP requests out-of-order, possibly resulting in information disclosure. This vulnerability is fixed in 24.7.0rc1.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"twisted.web has disordered HTTP pipeline response","id":"CVE-2024-41671","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"information_disclosure","year":"2024"},"n_packages":4,"n_references":3,"next":{"headline":"DuckDB: sniff_csv provides filesystem access even when enable_external_access is disabled","id":"CVE-2024-41672"},"packages":[{"ecosystem":"PyPI","fixed":["24.7.0rc1"],"introduced":["0"],"last_affected":[],"package":"twisted","purl":null,"source":"GHSA-c8m8-j448-xjx7"},{"ecosystem":"PyPI","fixed":["24.7.0rc1"],"introduced":["0"],"last_affected":[],"package":"twisted","purl":"pkg:pypi/twisted","source":"GHSA-c8m8-j448-xjx7"},{"ecosystem":"PyPI","fixed":["24.7.0rc1"],"introduced":["0"],"last_affected":[],"package":"twisted","purl":"pkg:pypi/twisted","source":"PYSEC-2026-1992"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.112.0-1.1"],"introduced":["0"],"last_affected":[],"package":"matrix-synapse","purl":"pkg:rpm/opensuse/matrix-synapse\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:14228-1"}],"prev":{"headline":"PayPal Official Module for PrestaShop has Improperly Implemented Security Check for Standard","id":"CVE-2024-41670"},"products":["twisted"],"published":"2024-07-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["twisted"]},"summary":"Attackers can exploit HTTP request pipelining in Twisted to receive responses out of order, potentially leaking sensitive information from other users.","url":"https://insights.sbomify.com/CVE-2024-41671/"}