# CVE-2024-41671: twisted.web has disordered HTTP pipeline response

> Attackers can exploit HTTP request pipelining in Twisted to receive responses out of order, potentially leaking sensitive information from other users.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jul 2024
- **Updated:** 3 Nov 2025
- **Also known as:** AZL-47101, AZL-47151, DEBIAN-CVE-2024-41671, GHSA-c8m8-j448-xjx7, PYSEC-2026-1992, UBUNTU-CVE-2024-41671, USN-6988-2, openSUSE-SU-2024:14228-1

## What is CVE-2024-41671?

CVE-2024-41671 is a high-severity vulnerability in twisted, published on 29 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Twisted is an event-based framework for internet applications, supporting Python 3.6+. The HTTP 1.0 and 1.1 server provided by twisted.web could process pipelined HTTP requests out-of-order, possibly resulting in information disclosure. This vulnerability is fixed in 24.7.0rc1.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2024-41671?

3 open source packages ship an affected version, including twisted.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `twisted` | PyPI | All versions | 24.7.0rc1 |
| `twisted` | PyPI | All versions | 24.7.0rc1 |
| `twisted` | PyPI | All versions | 24.7.0rc1 |
| `matrix-synapse` | openSUSE:Tumbleweed | All versions | 1.112.0-1.1 |

## How do I fix CVE-2024-41671?

Upgrade twisted to 24.7.0rc1 or later.

## Is CVE-2024-41671 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-41671 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-41671 and fix it if it is affected.

What it is: CVE-2024-41671 is a high-severity vulnerability in twisted, published on 29 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-41671 exists.

Affected packages and fixed versions:
- twisted (PyPI): affected all versions; fixed in 24.7.0rc1
- twisted (PyPI): affected all versions; fixed in 24.7.0rc1
- twisted (PyPI): affected all versions; fixed in 24.7.0rc1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-41671/ (Markdown: https://insights.sbomify.com/CVE-2024-41671/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-41671
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-41671
- OSV: https://osv.dev/vulnerability/CVE-2024-41671

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-41671/
Summaries are generated and may contain mistakes; the official description above is the record.
