{"answers":{"affected":"3 open source packages ship an affected version, including duckdb. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-41672 exists.","fix":"Upgrade duckdb to 1.1.0 or later.","what":"CVE-2024-41672 is a high-severity path traversal vulnerability in duckdb, published on 24 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-41672 and fix it if it is affected.\n\nWhat it is: CVE-2024-41672 is a high-severity path traversal vulnerability in duckdb, published on 24 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-41672 exists.\n\nAffected packages and fixed versions:\n- duckdb (PyPI): affected all versions; fixed in 1.1.0\n- duckdb (PyPI): affected from 1.0.0; fixed in 1.1.0\n- duckdb (PyPI): affected from 1.0.0; fixed in 1.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-41672/ (Markdown: https://insights.sbomify.com/CVE-2024-41672/index.md)","id":"CVE-2024-41672","markdown":"https://insights.sbomify.com/CVE-2024-41672/index.md","name":"CVE-2024-41672","record":{"aliases":["GHSA-w2gf-jxc9-pf2q","JLSEC-2026-774","PYSEC-2024-203"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"DuckDB database","requires_auth":"none","summary":"Attackers can read arbitrary filesystem files via sniff_csv in DuckDB, bypassing external access restrictions.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"duckdb","vendor":"duckdb"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"DuckDB is a SQL database management system. In versions 1.0.0 and prior, content in filesystem is accessible for reading using `sniff_csv`, even with `enable_external_access=false`. This vulnerability provides an attacker with access to filesystem even when access is expected to be disabled and other similar functions do NOT provide access. There seem to be two vectors to this vulnerability. First, access to files that should otherwise not be allowed. Second, the content from a file can be read (e.g. `/etc/hosts`, `proc/self/environ`, etc) even though that doesn't seem to be the intent of the sniff_csv function. A fix for this issue is available in commit c9b7c98aa0e1cd7363fe8bb8543a95f38e980d8a and is expected to be part of version 1.1.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"DuckDB: sniff_csv provides filesystem access even when enable_external_access is disabled","id":"CVE-2024-41672","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2024"},"n_packages":3,"n_references":3,"next":{"headline":"Decidim has a cross-site scripting vulnerability in the version control page","id":"CVE-2024-41673"},"packages":[{"ecosystem":"PyPI","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"duckdb","purl":"pkg:pypi/duckdb","source":"PYSEC-2024-203"},{"ecosystem":"PyPI","fixed":["1.1.0"],"introduced":["1.0.0"],"last_affected":[],"package":"duckdb","purl":null,"source":"GHSA-w2gf-jxc9-pf2q"},{"ecosystem":"PyPI","fixed":["1.1.0"],"introduced":["1.0.0"],"last_affected":[],"package":"duckdb","purl":"pkg:pypi/duckdb","source":"GHSA-w2gf-jxc9-pf2q"}],"prev":{"headline":"twisted.web has disordered HTTP pipeline response","id":"CVE-2024-41671"},"products":["duckdb"],"published":"2024-07-24","related":[{"cvss_score":6.9,"headline":"DuckDB Encryption Crypto implementation is vulnerable","id":"CVE-2025-64429","kev_date_added":null,"published":"2025-11-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["duckdb"]},"summary":"Attackers can read arbitrary filesystem files via sniff_csv in DuckDB, bypassing external access restrictions.","url":"https://insights.sbomify.com/CVE-2024-41672/"}