{"answers":{"affected":"2 open source packages ship an affected version, including decidim.","exploited":"There is no known exploitation of CVE-2024-41673 in the wild and no public exploit code.","fix":"Upgrade decidim to 0.27.8 or later.","what":"CVE-2024-41673 is a high-severity cross-site scripting vulnerability in decidim, published on 1 Oct 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-41673 and fix it if it is affected.\n\nWhat it is: CVE-2024-41673 is a high-severity cross-site scripting vulnerability in decidim, published on 1 Oct 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-41673 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- decidim (RubyGems): affected all versions; fixed in 0.27.8\n- decidim (RubyGems): affected all versions; fixed in 0.27.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-41673/ (Markdown: https://insights.sbomify.com/CVE-2024-41673/index.md)","id":"CVE-2024-41673","markdown":"https://insights.sbomify.com/CVE-2024-41673/index.md","name":"CVE-2024-41673","record":{"aliases":["GHSA-cc4g-m3g7-xmw8"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Decidim participatory democracy","requires_auth":"none","summary":"An attacker can execute arbitrary scripts in the version control page via a malformed URL, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Decidim is a participatory democracy framework. The version control feature used in resources is subject to potential XSS attack through a malformed URL. This vulnerability is fixed in 0.27.8.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Decidim has a cross-site scripting vulnerability in the version control page","id":"CVE-2024-41673","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"CKAN may leak Solr credentials via error message in package_search action","id":"CVE-2024-41674"},"packages":[{"ecosystem":"RubyGems","fixed":["0.27.8"],"introduced":["0"],"last_affected":[],"package":"decidim","purl":null,"source":"GHSA-cc4g-m3g7-xmw8"},{"ecosystem":"RubyGems","fixed":["0.27.8"],"introduced":["0"],"last_affected":[],"package":"decidim","purl":"pkg:gem/decidim","source":"GHSA-cc4g-m3g7-xmw8"}],"prev":{"headline":"DuckDB: sniff_csv provides filesystem access even when enable_external_access is disabled","id":"CVE-2024-41672"},"products":["decidim"],"published":"2024-10-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-01","vendors":["decidim"]},"summary":"An attacker can execute arbitrary scripts in the version control page via a malformed URL, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2024-41673/"}