# CVE-2024-41674: CKAN may leak Solr credentials via error message in package_search action

> Attackers can obtain Solr credentials from error messages during connection failures, potentially compromising the data portal's search backend.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Aug 2024
- **Updated:** 21 Aug 2024
- **Also known as:** GHSA-2rqw-cfhc-35fh, PYSEC-2026-1248

## What is CVE-2024-41674?

CVE-2024-41674 is a medium-severity vulnerability in ckan, published on 21 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CKAN is an open-source data management system for powering data hubs and data portals. If there were connection issues with the Solr server, the internal Solr URL (potentially including credentials) could be leaked to package_search calls as part of the returned error message. This has been patched in CKAN 2.10.5 and 2.11.0.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2024-41674?

3 open source packages ship an affected version, including ckan. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ckan` | PyPI | From 2.0.0 | 2.10.5 |
| `ckan` | PyPI | From 2.0.0 | 2.10.5 |
| `ckan` | PyPI | From 2.0.0 | 2.10.5 |

Products: Okfn Ckan.

## How do I fix CVE-2024-41674?

Upgrade ckan to 2.10.5 or later.

## Is CVE-2024-41674 being exploited?

There is no known exploitation of CVE-2024-41674 in the wild and no public exploit code.

## Other vulnerabilities in ckan

- [CVE-2023-32321](https://insights.sbomify.com/CVE-2023-32321/): CKAN remote code execution and private information access via crafted resource ids (critical 9.8)
- [CVE-2023-32696](https://insights.sbomify.com/CVE-2023-32696/): Excessive permissions for ckan user (high 8.8)
- [CVE-2022-43685](https://insights.sbomify.com/CVE-2022-43685/): CKAN contains Improper Authentication leading to account takeover (high 8.8)
- [CVE-2023-22746](https://insights.sbomify.com/CVE-2023-22746/): CKAN is vulnerable to session secret shared across instances using Docker images (high 8.6)
- [CVE-2026-42031](https://insights.sbomify.com/CVE-2026-42031/): CKAN: Unauthenticated SQL Injection and Authorization Bypass in `datastore_search_sql` (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-41674 and fix it if it is affected.

What it is: CVE-2024-41674 is a medium-severity vulnerability in ckan, published on 21 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-41674 in the wild and no public exploit code.

Affected packages and fixed versions:
- ckan (PyPI): affected from 2.0.0; fixed in 2.10.5
- ckan (PyPI): affected from 2.0.0; fixed in 2.10.5
- ckan (PyPI): affected from 2.0.0; fixed in 2.10.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-41674/ (Markdown: https://insights.sbomify.com/CVE-2024-41674/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-41674
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-41674
- OSV: https://osv.dev/vulnerability/CVE-2024-41674

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-41674/
Summaries are generated and may contain mistakes; the official description above is the record.
