CVE-2024-41675 CKAN has a Cross-site Scripting vector in the Datatables view plugin

Medium 6.8 Published Updated

Attackers can inject malicious scripts via unescaped DataStore records in the Datatables view plugin, potentially compromising user sessions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-41675?

CVE-2024-41675 is a medium-severity cross-site scripting vulnerability in ckan, published on 21 Aug 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

CKAN is an open-source data management system for powering data hubs and data portals. The Datatables view plugin did not properly escape record data coming from the DataStore, leading to a potential XSS vector. Sites running CKAN >= 2.7.0 with the datatables_view plugin activated. This is a plugin included in CKAN core, that not activated by default but it is widely used to preview tabular data. This vulnerability has been fixed in CKAN 2.10.5 and 2.11.0.

Weakness: CWE-79

Which versions are affected by CVE-2024-41675?

3 open source packages ship an affected version, including ckan. It affects 1 product.

PackageAffectedFixed in
ckan PyPIFrom 2.7.02.10.5
ckan PyPIFrom 2.7.02.10.5
ckan PyPIFrom 2.7.02.10.5

Products include Okfn Ckan.

How do I fix CVE-2024-41675?

Upgrade ckan to 2.10.5 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-41675 being exploited?

There is no known exploitation of CVE-2024-41675 in the wild and no public exploit code.

Sources

Also known as GHSA-r3jc-vhf4-6v32, PYSEC-2026-1253.

Is CVE-2024-41675 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free