{"answers":{"affected":"2 open source packages ship an affected version, including openmage/magento-lts. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-41676 in the wild and no public exploit code.","fix":"Upgrade openmage/magento-lts to 20.10.1 or later.","what":"CVE-2024-41676 is a medium-severity cross-site scripting vulnerability in OpenMage magento-lts, published on 29 Jul 2024. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-41676 and fix it if it is affected.\n\nWhat it is: CVE-2024-41676 is a medium-severity cross-site scripting vulnerability in OpenMage magento-lts, published on 29 Jul 2024. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-41676 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openmage/magento-lts (Packagist): affected all versions; fixed in 20.10.1\n- openmage/magento-lts (Packagist): affected all versions; fixed in 20.10.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-41676/ (Markdown: https://insights.sbomify.com/CVE-2024-41676/index.md)","id":"CVE-2024-41676","markdown":"https://insights.sbomify.com/CVE-2024-41676/index.md","name":"CVE-2024-41676","record":{"aliases":["GHSA-5vrp-638w-p8m2"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Magento LTS","requires_auth":"high_privilege","summary":"Attackers can inject arbitrary JavaScript into admin system configs, potentially leading to code execution or account takeover in Magento LTS.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"magento","vendor":"openmage"}],"cvss":{"score":4.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Magento-lts is a long-term support alternative to Magento Community Edition (CE). This XSS vulnerability affects the design/header/welcome, design/header/logo_src, design/header/logo_src_small, and design/header/logo_alt system configs.They are intended to enable admins to set a text in the two cases, and to define an image url for the other two cases.\nBut because of previously missing escaping allowed to input arbitrary html and as a consequence also arbitrary JavaScript. The problem is patched with Version 20.10.1 or higher.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Magento LTS vulnerable to stored Cross-site Scripting (XSS) in admin system configs","id":"CVE-2024-41676","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-site Scripting (XSS) vulnerability due to improper HTML escaping in qwik","id":"CVE-2024-41677"},"packages":[{"ecosystem":"Packagist","fixed":["20.10.1"],"introduced":["0"],"last_affected":[],"package":"openmage/magento-lts","purl":null,"source":"GHSA-5vrp-638w-p8m2"},{"ecosystem":"Packagist","fixed":["20.10.1"],"introduced":["0"],"last_affected":[],"package":"openmage/magento-lts","purl":"pkg:composer/openmage/magento-lts","source":"GHSA-5vrp-638w-p8m2"}],"prev":{"headline":"CKAN has a Cross-site Scripting vector in the Datatables view plugin","id":"CVE-2024-41675"},"products":["magento-lts"],"published":"2024-07-29","related":[{"cvss_score":9.8,"headline":"Fixes a bug in Zend Framework's Stream HTTP Wrapper","id":"CVE-2021-21426","kev_date_added":null,"published":"2021-04-21"},{"cvss_score":9.1,"headline":"Backport for CVE-2021-21024 Blind SQLi from Magento 2","id":"CVE-2021-21427","kev_date_added":null,"published":"2021-04-21"},{"cvss_score":8.8,"headline":"OpenMage LTS authenticated remote code execution through layout update","id":"CVE-2021-41144","kev_date_added":null,"published":"2023-01-27"},{"cvss_score":8.7,"headline":"OpenMage LTS has Customer File Upload Extension Blocklist Bypass that Leads to Remote Code Execution","id":"CVE-2026-40488","kev_date_added":null,"published":"2026-04-20"},{"cvss_score":8.1,"headline":"OpenMage LTS's Phar Deserialization leads to Remote Code Execution","id":"CVE-2026-25524","kev_date_added":null,"published":"2026-04-20"},{"cvss_score":8,"headline":"RCE in Magento","id":"CVE-2020-15244","kev_date_added":null,"published":"2020-10-21"},{"cvss_score":7.5,"headline":"Magento LTS's guest order \"protect code\" can be brute-forced too easily","id":"CVE-2023-41879","kev_date_added":null,"published":"2023-09-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["OpenMage"]},"summary":"Attackers can inject arbitrary JavaScript into admin system configs, potentially leading to code execution or account takeover in Magento LTS.","url":"https://insights.sbomify.com/CVE-2024-41676/"}