# CVE-2024-41676: Magento LTS vulnerable to stored Cross-site Scripting (XSS) in admin system configs

> Attackers can inject arbitrary JavaScript into admin system configs, potentially leading to code execution or account takeover in Magento LTS.

- **Severity:** Medium 4.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-5vrp-638w-p8m2

## What is CVE-2024-41676?

CVE-2024-41676 is a medium-severity cross-site scripting vulnerability in OpenMage magento-lts, published on 29 Jul 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Magento-lts is a long-term support alternative to Magento Community Edition (CE). This XSS vulnerability affects the design/header/welcome, design/header/logo_src, design/header/logo_src_small, and design/header/logo_alt system configs.They are intended to enable admins to set a text in the two cases, and to define an image url for the other two cases.
But because of previously missing escaping allowed to input arbitrary html and as a consequence also arbitrary JavaScript. The problem is patched with Version 20.10.1 or higher.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-41676?

2 open source packages ship an affected version, including openmage/magento-lts. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openmage/magento-lts` | Packagist | All versions | 20.10.1 |
| `openmage/magento-lts` | Packagist | All versions | 20.10.1 |

Products: Openmage Magento.

## How do I fix CVE-2024-41676?

Upgrade openmage/magento-lts to 20.10.1 or later.

## Is CVE-2024-41676 being exploited?

There is no known exploitation of CVE-2024-41676 in the wild and no public exploit code.

## Other vulnerabilities in OpenMage magento-lts

- [CVE-2021-21426](https://insights.sbomify.com/CVE-2021-21426/): Fixes a bug in Zend Framework's Stream HTTP Wrapper (critical 9.8)
- [CVE-2021-21427](https://insights.sbomify.com/CVE-2021-21427/): Backport for CVE-2021-21024 Blind SQLi from Magento 2 (critical 9.1)
- [CVE-2021-41144](https://insights.sbomify.com/CVE-2021-41144/): OpenMage LTS authenticated remote code execution through layout update (high 8.8)
- [CVE-2026-40488](https://insights.sbomify.com/CVE-2026-40488/): OpenMage LTS has Customer File Upload Extension Blocklist Bypass that Leads to Remote Code Execution (high 8.7)
- [CVE-2026-25524](https://insights.sbomify.com/CVE-2026-25524/): OpenMage LTS's Phar Deserialization leads to Remote Code Execution (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-41676 and fix it if it is affected.

What it is: CVE-2024-41676 is a medium-severity cross-site scripting vulnerability in OpenMage magento-lts, published on 29 Jul 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-41676 in the wild and no public exploit code.

Affected packages and fixed versions:
- openmage/magento-lts (Packagist): affected all versions; fixed in 20.10.1
- openmage/magento-lts (Packagist): affected all versions; fixed in 20.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-41676/ (Markdown: https://insights.sbomify.com/CVE-2024-41676/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-41676
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-41676
- OSV: https://osv.dev/vulnerability/CVE-2024-41676

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-41676/
Summaries are generated and may contain mistakes; the official description above is the record.
