# CVE-2024-41677: Cross-site Scripting (XSS) vulnerability due to improper HTML escaping in qwik

> Attackers can execute arbitrary scripts via mutation XSS due to improper HTML escaping during server-side rendering in the Qwik framework.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Aug 2024
- **Updated:** 8 Aug 2024
- **Also known as:** GHSA-2rwj-7xq8-4gx4

## What is CVE-2024-41677?

CVE-2024-41677 is a medium-severity cross-site scripting vulnerability in QwikDev qwik, published on 6 Aug 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Qwik is a performance focused javascript framework. A potential mutation XSS vulnerability exists in Qwik for versions up to but not including 1.6.0. Qwik improperly escapes HTML on server-side rendering. It converts strings according to the rules found in the `render-ssr.ts` file. It sometimes causes the situation that the final DOM tree rendered on browsers is different from what Qwik expects on server-side rendering. This may be leveraged to perform XSS attacks, and a type of the XSS is known as mXSS (mutation XSS). This has been resolved in qwik version 1.6.0 and @builder.io/qwik version 1.7.3. All users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-41677?

2 open source packages ship an affected version, including @builder.io/qwik. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@builder.io/qwik` | npm | All versions | 1.7.3 |
| `@builder.io/qwik` | npm | All versions | 1.7.3 |

Products: Qwik Qwik.

## How do I fix CVE-2024-41677?

Upgrade @builder.io/qwik to 1.7.3 or later.

## Is CVE-2024-41677 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-41677 exists.

## Other vulnerabilities in QwikDev qwik

- [CVE-2023-1283](https://insights.sbomify.com/CVE-2023-1283/): Code Injection in builderio/qwik (critical 10.0)
- [CVE-2026-25150](https://insights.sbomify.com/CVE-2026-25150/): Prototype Pollution via FormData Processing in Qwik City (critical 9.3)
- [CVE-2026-27971](https://insights.sbomify.com/CVE-2026-27971/): Qwik affected by unauthenticated RCE via server$ Deserialization (critical 9.2)
- [CVE-2026-32701](https://insights.sbomify.com/CVE-2026-32701/): Qwik has array method pollution in FormData processing, allowing type confusion and DoS (high 7.5)
- [CVE-2023-0410](https://insights.sbomify.com/CVE-2023-0410/): Cross-site Scripting (XSS) - Generic in builderio/qwik (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-41677 and fix it if it is affected.

What it is: CVE-2024-41677 is a medium-severity cross-site scripting vulnerability in QwikDev qwik, published on 6 Aug 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-41677 exists.

Affected packages and fixed versions:
- @builder.io/qwik (npm): affected all versions; fixed in 1.7.3
- @builder.io/qwik (npm): affected all versions; fixed in 1.7.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-41677/ (Markdown: https://insights.sbomify.com/CVE-2024-41677/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-41677
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-41677
- OSV: https://osv.dev/vulnerability/CVE-2024-41677

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-41677/
Summaries are generated and may contain mistakes; the official description above is the record.
