CVE-2024-41709 Backdrop CMS does not sufficiently sanitize field labels before they are displayed in certain places
An attacker with field administration permissions can inject malicious scripts via unsanitized field labels in Backdrop CMS.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-41709?
CVE-2024-41709 is a medium-severity cross-site scripting vulnerability in n/a, published on 22 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Backdrop CMS before 1.27.3 and 1.28.x before 1.28.2 does not sufficiently sanitize field labels before they are displayed in certain places. This vulnerability is mitigated by the fact that an attacker must have a role with the "administer fields" permission.
Weakness: CWE-79
Which versions are affected by CVE-2024-41709?
4 open source packages ship an affected version, including backdrop/backdrop. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
backdrop/backdrop Packagist | All versions | 1.27.3 |
backdrop/backdrop Packagist | All versions | 1.27.3 |
backdrop/backdrop Packagist | From 1.28.0 | 1.28.2 |
backdrop/backdrop Packagist | From 1.28.0 | 1.28.2 |
Products include Backdropcms Backdrop.
How do I fix CVE-2024-41709?
Upgrade backdrop/backdrop to a fixed version for your release line: 1.27.3 or 1.28.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-41709 being exploited?
There is no known exploitation of CVE-2024-41709 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-3wmx-48g3-x66g.