# CVE-2024-41800: Craft CMS Allows TOTP Token To Stay Valid After Use

> Attackers with valid credentials can reuse TOTP tokens to bypass two-factor authentication and hijack user accounts.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-wmx7-pw49-88jx

## What is CVE-2024-41800?

CVE-2024-41800 is a medium-severity authentication bypass vulnerability in Craftcms Craft Cms, published on 25 Jul 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Craft is a content management system (CMS). Craft CMS 5 allows reuse of TOTP tokens multiple times within the validity period. An attacker is able to re-submit a valid TOTP token to establish an authenticated session. This requires that the attacker has knowledge of the victim's credentials. This has been patched in Craft 5.2.3.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2024-41800?

2 open source packages ship an affected version, including craftcms/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | From 5.0.0-beta.1 | 5.2.3 |
| `craftcms/cms` | Packagist | From 5.0.0-beta.1 | 5.2.3 |

Products: Craftcms Craft Cms.

## How do I fix CVE-2024-41800?

Upgrade craftcms/cms to 5.2.3 or later.

## Is CVE-2024-41800 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-41800 exists.

## Other vulnerabilities in Craftcms Craft Cms

- [CVE-2025-32432](https://insights.sbomify.com/CVE-2025-32432/): Craft CMS Code Injection (critical 10.0, exploited in the wild)
- [CVE-2024-56145](https://insights.sbomify.com/CVE-2024-56145/): Craft CMS Code Injection (critical 9.3, exploited in the wild)
- [CVE-2025-23209](https://insights.sbomify.com/CVE-2025-23209/): Craft CMS Code Injection (high 8.1, exploited in the wild)
- [CVE-2025-35939](https://insights.sbomify.com/CVE-2025-35939/): Craft CMS External Control of Assumed-Immutable Web Parameter (medium 6.9, exploited in the wild)
- [CVE-2023-41892](https://insights.sbomify.com/CVE-2023-41892/): Craft CMS Remote Code Execution vulnerability (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-41800 and fix it if it is affected.

What it is: CVE-2024-41800 is a medium-severity authentication bypass vulnerability in Craftcms Craft Cms, published on 25 Jul 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-41800 exists.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected from 5.0.0-beta.1; fixed in 5.2.3
- craftcms/cms (Packagist): affected from 5.0.0-beta.1; fixed in 5.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-41800/ (Markdown: https://insights.sbomify.com/CVE-2024-41800/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-41800
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-41800
- OSV: https://osv.dev/vulnerability/CVE-2024-41800

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-41800/
Summaries are generated and may contain mistakes; the official description above is the record.
