# CVE-2024-4181: Command Injection in run-llama/llama_index

> A malicious LLM provider can execute arbitrary commands on client machines via improper eval usage in the RunGptLLM class.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 May 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-pw38-xv9x-h8ch, PYSEC-2024-324, PYSEC-2026-1565

## What is CVE-2024-4181?

CVE-2024-4181 is a high-severity code injection vulnerability in run-llama/llama_index, published on 16 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A command injection vulnerability exists in the RunGptLLM class of the llama_index library, version 0.9.47, used by the RunGpt framework from JinaAI to connect to Language Learning Models (LLMs). The vulnerability arises from the improper use of the eval function, allowing a malicious or compromised LLM hosting provider to execute arbitrary commands on the client's machine. This issue was fixed in version 0.10.13. The exploitation of this vulnerability could lead to a hosting provider gaining full control over client machines.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-4181?

6 open source packages ship an affected version, including llama-index and llama-index-llms-rungpt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `llama-index` | PyPI | All versions | 0.10.13 |
| `llama-index` | PyPI | All versions | 0.10.13 |
| `llama-index` | PyPI | From 0.9.47 | 0.10.13 |
| `llama-index-llms-rungpt` | PyPI | All versions | 0.1.3 |
| `llama-index-llms-rungpt` | PyPI | All versions | 0.1.3 |
| `llama-index-llms-rungpt` | PyPI | All versions | 0.1.3 |

Products: Llamaindex Llamaindex.

## How do I fix CVE-2024-4181?

Upgrade llama-index to 0.10.13 or later.

## Is CVE-2024-4181 being exploited?

There is no known exploitation of CVE-2024-4181 in the wild and no public exploit code.

## Other vulnerabilities in run-llama/llama_index

- [CVE-2024-12909](https://insights.sbomify.com/CVE-2024-12909/): SQL Injection to RCE in run-llama/llama_index (critical 10.0)
- [CVE-2025-1793](https://insights.sbomify.com/CVE-2025-1793/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2025-1750](https://insights.sbomify.com/CVE-2025-1750/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-11958](https://insights.sbomify.com/CVE-2024-11958/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-3271](https://insights.sbomify.com/CVE-2024-3271/): Command Injection in run-llama/llama_index (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-4181 and fix it if it is affected.

What it is: CVE-2024-4181 is a high-severity code injection vulnerability in run-llama/llama_index, published on 16 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-4181 in the wild and no public exploit code.

Affected packages and fixed versions:
- llama-index (PyPI): affected all versions; fixed in 0.10.13
- llama-index (PyPI): affected all versions; fixed in 0.10.13
- llama-index (PyPI): affected from 0.9.47; fixed in 0.10.13
- llama-index-llms-rungpt (PyPI): affected all versions; fixed in 0.1.3
- llama-index-llms-rungpt (PyPI): affected all versions; fixed in 0.1.3
- llama-index-llms-rungpt (PyPI): affected all versions; fixed in 0.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-4181/ (Markdown: https://insights.sbomify.com/CVE-2024-4181/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-4181
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-4181
- OSV: https://osv.dev/vulnerability/CVE-2024-4181

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-4181/
Summaries are generated and may contain mistakes; the official description above is the record.
