# CVE-2024-41810: HTML injection in HTTP redirect body

> Attackers can inject malicious HTML into redirect responses via controlled URLs, leading to reflected XSS in applications using Twisted.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Jul 2024
- **Updated:** 3 Nov 2025
- **Also known as:** AZL-47073, AZL-47195, DEBIAN-CVE-2024-41810, GHSA-cf56-g6w6-pqq2, PYSEC-2024-75, UBUNTU-CVE-2024-41810

## What is CVE-2024-41810?

CVE-2024-41810 is a medium-severity cross-site scripting vulnerability in twisted, published on 29 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Twisted is an event-based framework for internet applications, supporting Python 3.6+. The `twisted.web.util.redirectTo` function contains an HTML injection vulnerability. If application code allows an attacker to control the redirect URL this vulnerability may result in Reflected Cross-Site Scripting (XSS) in the redirect response HTML body. This vulnerability is fixed in 24.7.0rc1.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-41810?

3 open source packages ship an affected version, including twisted. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `twisted` | PyPI | All versions | 24.7.0rc1 |
| `twisted` | PyPI | All versions | 24.7.0rc1 |
| `twisted` | PyPI | All versions | 24.7.0rc1 |

Products: Twisted Twisted.

## How do I fix CVE-2024-41810?

Upgrade twisted to 24.7.0rc1 or later.

## Is CVE-2024-41810 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-41810 exists.

Public exploit code:

- Twisted - Open Redirect & XSS (nuclei): http/cves/2024/CVE-2024-41810.yaml

## Other vulnerabilities in twisted

- [CVE-2026-42304](https://insights.sbomify.com/CVE-2026-42304/): Twisted: Denial of Service (DoS) in twisted.names via Crafted DNS Compression Pointer Chains (high 7.5)
- [CVE-2014-7143](https://insights.sbomify.com/CVE-2014-7143/): Python Twisted trustRoot is not respected in HTTP client (high 7.5)
- [CVE-2019-12855](https://insights.sbomify.com/CVE-2019-12855/): Improper Certificate Validation in Twisted (high 7.4)
- [CVE-2023-46137](https://insights.sbomify.com/CVE-2023-46137/): twisted.web has disordered HTTP pipeline response (medium 5.3)
- [CVE-2016-1000111](https://insights.sbomify.com/CVE-2016-1000111/): Forced Browsing in Twisted (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-41810 and fix it if it is affected.

What it is: CVE-2024-41810 is a medium-severity cross-site scripting vulnerability in twisted, published on 29 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-41810 exists.

Affected packages and fixed versions:
- twisted (PyPI): affected all versions; fixed in 24.7.0rc1
- twisted (PyPI): affected all versions; fixed in 24.7.0rc1
- twisted (PyPI): affected all versions; fixed in 24.7.0rc1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-41810/ (Markdown: https://insights.sbomify.com/CVE-2024-41810/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-41810
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-41810
- OSV: https://osv.dev/vulnerability/CVE-2024-41810

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-41810/
Summaries are generated and may contain mistakes; the official description above is the record.
