CVE-2024-41811 ipl/web susceptible to Cross-Site Request Forgery (CSRF)

Low 3.9 Published Updated

Attackers can perform unauthorized actions on behalf of authenticated users in Icinga web components via cross-site request forgery.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-41811?

CVE-2024-41811 is a low-severity vulnerability in Icinga ipl-web, published on 5 Aug 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

ipl/web is a set of common web components for php projects. Some of the recent development by Icinga is, under certain circumstances, susceptible to cross site request forgery. (CSRF). All affected products, in any version, will be unaffected by this once `icinga-php-library` is upgraded. Version 0.10.1 includes a fix for this. It will be published as part of the `icinga-php-library` v0.14.1 release.

Weakness: CWE-352

Which versions are affected by CVE-2024-41811?

2 open source packages ship an affected version, including ipl/web.

PackageAffectedFixed in
ipl/web PackagistAll versions0.10.1
ipl/web PackagistAll versions0.10.1

How do I fix CVE-2024-41811?

Upgrade ipl/web to 0.10.1 or later.

Is CVE-2024-41811 being exploited?

There is no known exploitation of CVE-2024-41811 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2024-41811, GHSA-w9pg-7c3h-fc8j, UBUNTU-CVE-2024-41811.

Is CVE-2024-41811 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free