# CVE-2024-41811: ipl/web susceptible to Cross-Site Request Forgery (CSRF)

> Attackers can perform unauthorized actions on behalf of authenticated users in Icinga web components via cross-site request forgery.

- **Severity:** Low 3.9 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Aug 2024
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2024-41811, GHSA-w9pg-7c3h-fc8j, UBUNTU-CVE-2024-41811

## What is CVE-2024-41811?

CVE-2024-41811 is a low-severity vulnerability in Icinga ipl-web, published on 5 Aug 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

ipl/web is a set of common web components for php projects. Some of the recent development by Icinga is, under certain circumstances, susceptible to cross site request forgery. (CSRF). All affected products, in any version, will be unaffected by this once `icinga-php-library` is upgraded. Version 0.10.1 includes a fix for this. It will be published as part of the `icinga-php-library` v0.14.1 release.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2024-41811?

2 open source packages ship an affected version, including ipl/web.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ipl/web` | Packagist | All versions | 0.10.1 |
| `ipl/web` | Packagist | All versions | 0.10.1 |

## How do I fix CVE-2024-41811?

Upgrade ipl/web to 0.10.1 or later.

## Is CVE-2024-41811 being exploited?

There is no known exploitation of CVE-2024-41811 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-41811 and fix it if it is affected.

What it is: CVE-2024-41811 is a low-severity vulnerability in Icinga ipl-web, published on 5 Aug 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-41811 in the wild and no public exploit code.

Affected packages and fixed versions:
- ipl/web (Packagist): affected all versions; fixed in 0.10.1
- ipl/web (Packagist): affected all versions; fixed in 0.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-41811/ (Markdown: https://insights.sbomify.com/CVE-2024-41811/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-41811
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-41811
- OSV: https://osv.dev/vulnerability/CVE-2024-41811

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-41811/
Summaries are generated and may contain mistakes; the official description above is the record.
