# CVE-2024-41815: Starship vulnerable to shell injection via undocumented, unpredictable shell expansion in custom commands

> Attackers can execute arbitrary commands via shell injection in custom commands within the Starship shell prompt, requiring specific user configurations.

- **Severity:** High 7.4 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-vx24-x4mv-vwr5, RUSTSEC-2024-0446

## What is CVE-2024-41815?

CVE-2024-41815 is a high-severity command injection vulnerability in starship, published on 26 Jul 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Starship is a cross-shell prompt. Starting in version 1.0.0 and prior to version 1.20.0, undocumented and unpredictable shell expansion and/or quoting rules make it easily to accidentally cause shell injection when using custom commands with starship in bash. This issue only affects users with custom commands, so the scope is limited, and without knowledge of others' commands, it could be hard to successfully target someone. Version 1.20.0 fixes the vulnerability.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2024-41815?

3 open source packages ship an affected version, including starship. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `starship` | crates.io | From 1.0.0 | 1.20.0 |
| `starship` | crates.io | From 1.0.0 | 1.20.0 |
| `starship` | crates.io | From 1.0.1-0 | 1.20.0 |

Products: Starship Starship.

## How do I fix CVE-2024-41815?

Upgrade starship to 1.20.0 or later.

## Is CVE-2024-41815 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-41815 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-41815 and fix it if it is affected.

What it is: CVE-2024-41815 is a high-severity command injection vulnerability in starship, published on 26 Jul 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-41815 exists.

Affected packages and fixed versions:
- starship (crates.io): affected from 1.0.0; fixed in 1.20.0
- starship (crates.io): affected from 1.0.0; fixed in 1.20.0
- starship (crates.io): affected from 1.0.1-0; fixed in 1.20.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-41815/ (Markdown: https://insights.sbomify.com/CVE-2024-41815/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-41815
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-41815
- OSV: https://osv.dev/vulnerability/CVE-2024-41815

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-41815/
Summaries are generated and may contain mistakes; the official description above is the record.
