CVE-2024-41818 ReDOS at currency parsing fast-xml-parser

High 7.5 Published Updated

A Regular Expression Denial of Service vulnerability in fast-xml-parser allows attackers to cause service disruption via crafted currency inputs.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-41818?

CVE-2024-41818 is a high-severity denial of service vulnerability in NaturalIntelligence fast-xml-parser, published on 29 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

fast-xml-parser is an open source, pure javascript xml parser. a ReDOS exists on currency.js. This vulnerability is fixed in 4.4.1.

Weakness: CWE-1333, CWE-400

Which versions are affected by CVE-2024-41818?

2 open source packages ship an affected version, including fast-xml-parser. It affects 1 product.

PackageAffectedFixed in
fast-xml-parser npmFrom 4.3.54.4.1
fast-xml-parser npmFrom 4.3.54.4.1

Products include Naturalintelligence Fast-Xml-Parser.

How do I fix CVE-2024-41818?

Upgrade fast-xml-parser to 4.4.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-41818 being exploited?

There is no known exploitation of CVE-2024-41818 in the wild and no public exploit code.

Sources

Also known as GHSA-mpg4-rc92-vx8v.

Is CVE-2024-41818 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free