{"answers":{"affected":"2 open source packages ship an affected version, including fast-xml-parser. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-41818 in the wild and no public exploit code.","fix":"Upgrade fast-xml-parser to 4.4.1 or later.","what":"CVE-2024-41818 is a high-severity denial of service vulnerability in NaturalIntelligence fast-xml-parser, published on 29 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-41818 and fix it if it is affected.\n\nWhat it is: CVE-2024-41818 is a high-severity denial of service vulnerability in NaturalIntelligence fast-xml-parser, published on 29 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-41818 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fast-xml-parser (npm): affected from 4.3.5; fixed in 4.4.1\n- fast-xml-parser (npm): affected from 4.3.5; fixed in 4.4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-41818/ (Markdown: https://insights.sbomify.com/CVE-2024-41818/index.md)","id":"CVE-2024-41818","markdown":"https://insights.sbomify.com/CVE-2024-41818/index.md","name":"CVE-2024-41818","record":{"aliases":["GHSA-mpg4-rc92-vx8v"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript XML parser","requires_auth":"none","summary":"A Regular Expression Denial of Service vulnerability in fast-xml-parser allows attackers to cause service disruption via crafted currency inputs.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fast-xml-parser","vendor":"naturalintelligence"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"fast-xml-parser is an open source, pure javascript xml parser. a ReDOS exists on currency.js. This vulnerability is fixed in 4.4.1.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ReDOS at currency parsing fast-xml-parser","id":"CVE-2024-41818","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":2,"n_references":4,"next":{"headline":"Note Mark has a stored XSS in the note link href attribute","id":"CVE-2024-41819"},"packages":[{"ecosystem":"npm","fixed":["4.4.1"],"introduced":["4.3.5"],"last_affected":[],"package":"fast-xml-parser","purl":null,"source":"GHSA-mpg4-rc92-vx8v"},{"ecosystem":"npm","fixed":["4.4.1"],"introduced":["4.3.5"],"last_affected":[],"package":"fast-xml-parser","purl":"pkg:npm/fast-xml-parser","source":"GHSA-mpg4-rc92-vx8v"}],"prev":{"headline":"Arbitrary Code Execution in `AppImage` version `ImageMagick`","id":"CVE-2024-41817"},"products":["fast-xml-parser"],"published":"2024-07-29","related":[{"cvss_score":9.3,"headline":"fast-xml-parser has an entity encoding bypass via regex injection in DOCTYPE entity names","id":"CVE-2026-25896","kev_date_added":null,"published":"2026-02-20"},{"cvss_score":7.5,"headline":"fast-xml-parser affected by numeric entity expansion bypassing all entity expansion limits (incomplete fix for CVE-2026-26278)","id":"CVE-2026-33036","kev_date_added":null,"published":"2026-03-20"},{"cvss_score":7.5,"headline":"fast-xml-parser affected by DoS through entity expansion in DOCTYPE (no expansion limit)","id":"CVE-2026-26278","kev_date_added":null,"published":"2026-02-19"},{"cvss_score":7.5,"headline":"fast-xml-parser has RangeError DoS Numeric Entities Bug","id":"CVE-2026-25128","kev_date_added":null,"published":"2026-01-30"},{"cvss_score":7.5,"headline":"Regex Injection via Doctype Entities","id":"CVE-2023-34104","kev_date_added":null,"published":"2023-06-06"},{"cvss_score":6.1,"headline":"fast-xml-parser XMLBuilder: XML Comment and CDATA Injection via Unescaped Delimiters","id":"CVE-2026-41650","kev_date_added":null,"published":"2026-05-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-11","vendors":["NaturalIntelligence"]},"summary":"A Regular Expression Denial of Service vulnerability in fast-xml-parser allows attackers to cause service disruption via crafted currency inputs.","url":"https://insights.sbomify.com/CVE-2024-41818/"}