# CVE-2024-41818: ReDOS at currency parsing fast-xml-parser

> A Regular Expression Denial of Service vulnerability in fast-xml-parser allows attackers to cause service disruption via crafted currency inputs.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jul 2024
- **Updated:** 11 Oct 2024
- **Also known as:** GHSA-mpg4-rc92-vx8v

## What is CVE-2024-41818?

CVE-2024-41818 is a high-severity denial of service vulnerability in NaturalIntelligence fast-xml-parser, published on 29 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

fast-xml-parser is an open source, pure javascript xml parser. a ReDOS exists on currency.js. This vulnerability is fixed in 4.4.1.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-41818?

2 open source packages ship an affected version, including fast-xml-parser. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fast-xml-parser` | npm | From 4.3.5 | 4.4.1 |
| `fast-xml-parser` | npm | From 4.3.5 | 4.4.1 |

Products: Naturalintelligence Fast-Xml-Parser.

## How do I fix CVE-2024-41818?

Upgrade fast-xml-parser to 4.4.1 or later.

## Is CVE-2024-41818 being exploited?

There is no known exploitation of CVE-2024-41818 in the wild and no public exploit code.

## Other vulnerabilities in NaturalIntelligence fast-xml-parser

- [CVE-2026-25896](https://insights.sbomify.com/CVE-2026-25896/): fast-xml-parser has an entity encoding bypass via regex injection in DOCTYPE entity names (critical 9.3)
- [CVE-2026-33036](https://insights.sbomify.com/CVE-2026-33036/): fast-xml-parser affected by numeric entity expansion bypassing all entity expansion limits (incomplete fix for CVE-2026-26278) (high 7.5)
- [CVE-2026-26278](https://insights.sbomify.com/CVE-2026-26278/): fast-xml-parser affected by DoS through entity expansion in DOCTYPE (no expansion limit) (high 7.5)
- [CVE-2026-25128](https://insights.sbomify.com/CVE-2026-25128/): fast-xml-parser has RangeError DoS Numeric Entities Bug (high 7.5)
- [CVE-2023-34104](https://insights.sbomify.com/CVE-2023-34104/): Regex Injection via Doctype Entities (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-41818 and fix it if it is affected.

What it is: CVE-2024-41818 is a high-severity denial of service vulnerability in NaturalIntelligence fast-xml-parser, published on 29 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-41818 in the wild and no public exploit code.

Affected packages and fixed versions:
- fast-xml-parser (npm): affected from 4.3.5; fixed in 4.4.1
- fast-xml-parser (npm): affected from 4.3.5; fixed in 4.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-41818/ (Markdown: https://insights.sbomify.com/CVE-2024-41818/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-41818
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-41818
- OSV: https://osv.dev/vulnerability/CVE-2024-41818

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-41818/
Summaries are generated and may contain mistakes; the official description above is the record.
