# CVE-2024-41820: Cluster-level privilege escalation in kubean

> Malicious users with worker node access can escalate privileges to control the entire Kubernetes cluster due to excessive RBAC permissions.

- **Severity:** Medium 6.0 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Aug 2024
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-3wfj-3x8q-hrpg, GO-2024-3039

## What is CVE-2024-41820?

CVE-2024-41820 is a medium-severity vulnerability in kubean-io kubean, published on 5 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Kubean is a cluster lifecycle management toolchain based on kubespray and other cluster LCM engine. The ClusterRole has `*` verbs of `*` resources. If a malicious user can access the worker node which has kubean's deployment, he/she can abuse these excessive permissions to do whatever he/she likes to the whole cluster, resulting in a cluster-level privilege escalation. This issue has been addressed in release version 0.18.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2024-41820?

3 open source packages ship an affected version, including github.com/kubean-io/kubean.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kubean-io/kubean` | Go | All versions | 0.18.0 |
| `github.com/kubean-io/kubean` | Go | All versions | 0.18.0 |
| `github.com/kubean-io/kubean` | Go | All versions | 0.18.0 |

## How do I fix CVE-2024-41820?

Upgrade github.com/kubean-io/kubean to 0.18.0 or later.

## Is CVE-2024-41820 being exploited?

There is no known exploitation of CVE-2024-41820 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-41820 and fix it if it is affected.

What it is: CVE-2024-41820 is a medium-severity vulnerability in kubean-io kubean, published on 5 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-41820 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/kubean-io/kubean (Go): affected all versions; fixed in 0.18.0
- github.com/kubean-io/kubean (Go): affected all versions; fixed in 0.18.0
- github.com/kubean-io/kubean (Go): affected all versions; fixed in 0.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-41820/ (Markdown: https://insights.sbomify.com/CVE-2024-41820/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-41820
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-41820
- OSV: https://osv.dev/vulnerability/CVE-2024-41820

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-41820/
Summaries are generated and may contain mistakes; the official description above is the record.
