# CVE-2024-4183: Mattermost fails to limit the number of active sessions

> An authenticated attacker can crash the Mattermost server by flooding the sessions table via repeated API requests, requiring an upgrade to patched versions.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Apr 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-wj37-mpq9-xrcm, GO-2024-2798

## What is CVE-2024-4183?

CVE-2024-4183 is a medium-severity denial of service vulnerability in Mattermost Mattermost Server, published on 26 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost versions 8.1.x before 8.1.12, 9.6.x before 9.6.1, 9.5.x before 9.5.3, 9.4.x before 9.4.5 fail to limit the number of active sessions, which allows an authenticated attacker to crash the server via repeated requests to the getSessions API after flooding the sessions table.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-4183?

9 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server` | Go | From 8.1.0 | 8.1.12 |
| `github.com/mattermost/mattermost-server` | Go | From 8.1.0 | 8.1.12 |
| `github.com/mattermost/mattermost-server` | Go | From 8.1.0+incompatible | 8.1.12+incompatible, 9.4.5+incompatible, 9.5.3+incompatible, 9.6.1+incompatible |
| `github.com/mattermost/mattermost-server` | Go | From 9.4.0 | 9.4.5 |
| `github.com/mattermost/mattermost-server` | Go | From 9.4.0 | 9.4.5 |
| `github.com/mattermost/mattermost-server` | Go | From 9.5.0 | 9.5.3 |
| `github.com/mattermost/mattermost-server` | Go | From 9.5.0 | 9.5.3 |
| `github.com/mattermost/mattermost-server` | Go | From 9.6.0-rc1 | 9.6.1 |
| `github.com/mattermost/mattermost-server` | Go | From 9.6.0-rc1 | 9.6.1 |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2024-4183?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 8.1.12, 8.1.12+incompatible, 9.4.5+incompatible or 9.5.3+incompatible.

## Is CVE-2024-4183 being exploited?

There is no known exploitation of CVE-2024-4183 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-4183 and fix it if it is affected.

What it is: CVE-2024-4183 is a medium-severity denial of service vulnerability in Mattermost Mattermost Server, published on 26 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-4183 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server (Go): affected from 8.1.0; fixed in 8.1.12
- github.com/mattermost/mattermost-server (Go): affected from 8.1.0; fixed in 8.1.12
- github.com/mattermost/mattermost-server (Go): affected from 8.1.0+incompatible; fixed in 8.1.12+incompatible, 9.4.5+incompatible, 9.5.3+incompatible, 9.6.1+incompatible
- github.com/mattermost/mattermost-server (Go): affected from 9.4.0; fixed in 9.4.5
- github.com/mattermost/mattermost-server (Go): affected from 9.4.0; fixed in 9.4.5
- github.com/mattermost/mattermost-server (Go): affected from 9.5.0; fixed in 9.5.3
- github.com/mattermost/mattermost-server (Go): affected from 9.5.0; fixed in 9.5.3
- github.com/mattermost/mattermost-server (Go): affected from 9.6.0-rc1; fixed in 9.6.1
- github.com/mattermost/mattermost-server (Go): affected from 9.6.0-rc1; fixed in 9.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-4183/ (Markdown: https://insights.sbomify.com/CVE-2024-4183/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-4183
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-4183
- OSV: https://osv.dev/vulnerability/CVE-2024-4183

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-4183/
Summaries are generated and may contain mistakes; the official description above is the record.
