# CVE-2024-41909: Apache MINA SSHD: integrity check bypass


- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 12 Aug 2024
- **Updated:** 27 Mar 2025
- **Also known as:** CLEANSTART-2026-HK92541, CLEANSTART-2026-IP32921, CLEANSTART-2026-UA87106, GHSA-2326-hx7g-3m9r, MINI-4rrg-7hvq-2rpr, MINI-mwg3-4prr-r9xm

## What is CVE-2024-41909?

CVE-2024-41909 is a medium-severity vulnerability in Apache MINA SSHD, published on 12 Aug 2024. 

### Official description

Like many other SSH implementations, Apache MINA SSHD suffered from the issue that is more widely known as CVE-2023-48795. An attacker that can intercept traffic between client and server could drop certain packets from the stream, potentially causing client and server to consequently end up with a connection for which 
some security features have been downgraded or disabled, aka a Terrapin 
attack

The mitigations to prevent this type of attack were implemented in Apache MINA SSHD 2.12.0, both client and server side. Users are recommended to upgrade to at least this version. Note that both the client and the server implementation must have mitigations applied against this issue, otherwise the connection may still be affected.

Weakness: CWE-354 (Improper Validation of Integrity Check Value)

## Which versions are affected by CVE-2024-41909?

2 open source packages ship an affected version, including org.apache.sshd:sshd-common. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.sshd:sshd-common` | Maven | All versions | 2.12.0 |
| `org.apache.sshd:sshd-common` | Maven | All versions | 2.12.0 |

Products: Apache Mina Sshd.

## How do I fix CVE-2024-41909?

Upgrade org.apache.sshd:sshd-common to 2.12.0 or later.

## Is CVE-2024-41909 being exploited?

There is no known exploitation of CVE-2024-41909 in the wild and no public exploit code.

## Other vulnerabilities in Apache MINA SSHD

- [CVE-2026-56452](https://insights.sbomify.com/CVE-2026-56452/): Apache MINA SSHD: Path traversal in SCP file reception (high 7.5)
- [CVE-2026-56624](https://insights.sbomify.com/CVE-2026-56624/): Apache MINA SSHD: SSH certificate options lack validations (high 7.3)
- [CVE-2026-56623](https://insights.sbomify.com/CVE-2026-56623/): Apache MINA SSHD: Path traversal in org.apache.sshd:sshd-git on Windows (high 7.1)
- [CVE-2026-48827](https://insights.sbomify.com/CVE-2026-48827/): Apache MINA SSHD: Path traversal in org.apache.sshd:sshd-git (high 7.1)
- [CVE-2019-6111](https://insights.sbomify.com/CVE-2019-6111/): Path traversal in n/a (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-41909 and fix it if it is affected.

What it is: CVE-2024-41909 is a medium-severity vulnerability in Apache MINA SSHD, published on 12 Aug 2024. 
Exploitation: There is no known exploitation of CVE-2024-41909 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.sshd:sshd-common (Maven): affected all versions; fixed in 2.12.0
- org.apache.sshd:sshd-common (Maven): affected all versions; fixed in 2.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-41909/ (Markdown: https://insights.sbomify.com/CVE-2024-41909/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-41909
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-41909
- OSV: https://osv.dev/vulnerability/CVE-2024-41909

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-41909/
Summaries are generated and may contain mistakes; the official description above is the record.
