CVE-2024-41926 Malicious remote can claim that a user was synced from another remote
A malicious remote can spoof user sync origins by bypassing validation, allowing unauthorized modification of user metadata in Mattermost.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-41926?
CVE-2024-41926 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 1 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Mattermost versions 9.9.x <= 9.9.0 and 9.5.x <= 9.5.6 fail to validate the source of sync messages and only allow the correct remote IDs, which allows a malicious remote to set arbitrary RemoteId values for synced users and therefore claim that a user was synced from another remote.
Which versions are affected by CVE-2024-41926?
13 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, mattermost and github.com/mattermost/mattermost. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20240604093018-5114c3b7cdb8 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20240604093018-5114c3b7cdb8 |
github.com/mattermost/mattermost/server/v8 Go | From 9.5.0 | 9.5.7 |
github.com/mattermost/mattermost/server/v8 Go | From 9.5.0 | 9.5.7 |
github.com/mattermost/mattermost/server/v8 Go | From 9.9.0 | 9.9.1 |
7 more packages
github.com/mattermost/mattermost/server/v8 Go | From 9.9.0 | 9.9.1 |
mattermost Bitnami | From 9.5.0 to 9.9.0 | 9.5.7 |
github.com/mattermost/mattermost Go | All versions | 5.3.2-0.20240604093018-5114c3b7cdb8 |
github.com/mattermost/mattermost Go | All versions | 5.3.2-0.20240604093018-5114c3b7cdb8 |
github.com/mattermost/mattermost-server Go | From 9.5.0+incompatible | 9.5.7+incompatible, 9.9.1+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2024-41926?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20240604093018-5114c3b7cdb8, 9.5.7 or 9.9.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-41926 being exploited?
There is no known exploitation of CVE-2024-41926 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as BIT-mattermost-2024-41926, GHSA-9fpw-c9x7-cv3j, GO-2024-3022.