{"answers":{"affected":"4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-41937 in the wild and no public exploit code.","fix":"Upgrade apache-airflow to 2.10.0 or later.","what":"CVE-2024-41937 is a medium-severity cross-site scripting vulnerability in Apache Airflow, published on 21 Aug 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-41937 and fix it if it is affected.\n\nWhat it is: CVE-2024-41937 is a medium-severity cross-site scripting vulnerability in Apache Airflow, published on 21 Aug 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-41937 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache-airflow (PyPI): affected all versions; fixed in 2.10.0\n- apache-airflow (PyPI): affected all versions; fixed in 2.10.0\n- apache-airflow (PyPI): affected all versions; fixed in 2.10.0\n- airflow (Bitnami): affected all versions; fixed in 2.10.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-41937/ (Markdown: https://insights.sbomify.com/CVE-2024-41937/index.md)","id":"CVE-2024-41937","markdown":"https://insights.sbomify.com/CVE-2024-41937/index.md","name":"CVE-2024-41937","record":{"aliases":["BIT-airflow-2024-41937","ECHO-8a2e-b832-32db","GHSA-w7cp-g8v7-r54m","PYSEC-2024-181"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Airflow","requires_auth":"none","summary":"A malicious provider developer can execute cross-site scripting attacks when users click provider documentation links in Apache Airflow.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"airflow","vendor":"apache"}],"cvss":{"score":6.1,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Apache Airflow, versions before 2.10.0, have a vulnerability that allows the developer of a malicious provider to execute a cross-site scripting attack when clicking on a provider documentation link. This would require the provider to be installed on the web server and the user to click the provider link.\nUsers should upgrade to 2.10.0 or later, which fixes this vulnerability.","ecosystems":["Bitnami","PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Airflow: Stored XSS Vulnerability on provider link","id":"CVE-2024-41937","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:airflow","products":["apache:airflow"],"type":"xss","year":"2024"},"n_packages":4,"n_references":2,"next":{"headline":"Path traversal in SINEC NMS","id":"CVE-2024-41938"},"packages":[{"ecosystem":"Bitnami","fixed":["2.10.0"],"introduced":["0"],"last_affected":[],"package":"airflow","purl":"pkg:bitnami/airflow","source":"BIT-airflow-2024-41937"},{"ecosystem":"PyPI","fixed":["2.10.0"],"introduced":["0"],"last_affected":[],"package":"apache-airflow","purl":null,"source":"GHSA-w7cp-g8v7-r54m"},{"ecosystem":"PyPI","fixed":["2.10.0"],"introduced":["0"],"last_affected":[],"package":"apache-airflow","purl":"pkg:pypi/apache-airflow","source":"GHSA-w7cp-g8v7-r54m"},{"ecosystem":"PyPI","fixed":["2.10.0"],"introduced":["0"],"last_affected":[],"package":"apache-airflow","purl":"pkg:pypi/apache-airflow","source":"PYSEC-2024-181"}],"prev":{"headline":"Vonets WiFi Bridges Path Traversal","id":"CVE-2024-41936"},"products":["Apache Airflow"],"published":"2024-08-21","related":[{"cvss_score":9.8,"headline":"Apache Airflow's Experimental API Authentication Bypass","id":"CVE-2020-13927","kev_date_added":"2022-01-18","published":"2020-11-10"},{"cvss_score":8.8,"headline":"Apache Airflow Command Injection","id":"CVE-2020-11978","kev_date_added":"2022-01-18","published":"2020-07-16"},{"cvss_score":9.8,"headline":"Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize()","id":"CVE-2026-33264","kev_date_added":null,"published":"2026-07-07"},{"cvss_score":9.8,"headline":"Apache Airflow: Privilege escalation using airflow logs","id":"CVE-2023-25754","kev_date_added":null,"published":"2023-05-08"},{"cvss_score":9.8,"headline":"Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow","id":"CVE-2023-22884","kev_date_added":null,"published":"2023-01-21"},{"cvss_score":9.8,"headline":"Apache Airflow Pinot provider allowed Command Injection","id":"CVE-2022-38649","kev_date_added":null,"published":"2022-11-22"},{"cvss_score":9.8,"headline":"Apache Airlfow Pig Provider RCE","id":"CVE-2022-40189","kev_date_added":null,"published":"2022-11-22"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-20","vendors":["Apache Software Foundation"]},"summary":"A malicious provider developer can execute cross-site scripting attacks when users click provider documentation links in Apache Airflow.","url":"https://insights.sbomify.com/CVE-2024-41937/"}