# CVE-2024-41937: Apache Airflow: Stored XSS Vulnerability on provider link

> A malicious provider developer can execute cross-site scripting attacks when users click provider documentation links in Apache Airflow.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Aug 2024
- **Updated:** 20 Mar 2025
- **Also known as:** BIT-airflow-2024-41937, ECHO-8a2e-b832-32db, GHSA-w7cp-g8v7-r54m, PYSEC-2024-181

## What is CVE-2024-41937?

CVE-2024-41937 is a medium-severity cross-site scripting vulnerability in Apache Airflow, published on 21 Aug 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Apache Airflow, versions before 2.10.0, have a vulnerability that allows the developer of a malicious provider to execute a cross-site scripting attack when clicking on a provider documentation link. This would require the provider to be installed on the web server and the user to click the provider link.
Users should upgrade to 2.10.0 or later, which fixes this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-41937?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 2.10.0 |
| `apache-airflow` | PyPI | All versions | 2.10.0 |
| `apache-airflow` | PyPI | All versions | 2.10.0 |
| `airflow` | Bitnami | All versions | 2.10.0 |

Products: Apache Airflow.

## How do I fix CVE-2024-41937?

Upgrade apache-airflow to 2.10.0 or later.

## Is CVE-2024-41937 being exploited?

There is no known exploitation of CVE-2024-41937 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-41937 and fix it if it is affected.

What it is: CVE-2024-41937 is a medium-severity cross-site scripting vulnerability in Apache Airflow, published on 21 Aug 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-41937 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 2.10.0
- apache-airflow (PyPI): affected all versions; fixed in 2.10.0
- apache-airflow (PyPI): affected all versions; fixed in 2.10.0
- airflow (Bitnami): affected all versions; fixed in 2.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-41937/ (Markdown: https://insights.sbomify.com/CVE-2024-41937/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-41937
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-41937
- OSV: https://osv.dev/vulnerability/CVE-2024-41937

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-41937/
Summaries are generated and may contain mistakes; the official description above is the record.
