{"answers":{"affected":"6 open source packages ship an affected version, including jupyterhub. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-41942 in the wild and no public exploit code.","fix":"Upgrade jupyterhub to a fixed version for your release line: 4.1.6 or 5.1.0.","what":"CVE-2024-41942 is a high-severity vulnerability in jupyterhub, published on 8 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-41942 and fix it if it is affected.\n\nWhat it is: CVE-2024-41942 is a high-severity vulnerability in jupyterhub, published on 8 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-41942 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- jupyterhub (Bitnami): affected all versions; fixed in 4.1.6, 5.1.0\n- jupyterhub (PyPI): affected all versions; fixed in 4.1.6\n- jupyterhub (PyPI): affected all versions; fixed in 4.1.6\n- jupyterhub (PyPI): affected all versions; fixed in 4.1.6\n- jupyterhub (PyPI): affected from 5.0.0; fixed in 5.1.0\n- jupyterhub (PyPI): affected from 5.0.0; fixed in 5.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-41942/ (Markdown: https://insights.sbomify.com/CVE-2024-41942/index.md)","id":"CVE-2024-41942","markdown":"https://insights.sbomify.com/CVE-2024-41942/index.md","name":"CVE-2024-41942","record":{"aliases":["BIT-jupyterhub-2024-41942","DEBIAN-CVE-2024-41942","GHSA-9x4q-3gxw-849f","PYSEC-2024-200","UBUNTU-CVE-2024-41942"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"JupyterHub","requires_auth":"high_privilege","summary":"Users with admin:users scope can escalate to full admin privileges in JupyterHub, requiring an upgrade to patched versions.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"jupyterhub","vendor":"jupyter"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-274","name":"Improper Handling of Insufficient Privileges"}],"description":"JupyterHub is software that allows one to create a multi-user server for Jupyter notebooks. Prior to versions 4.1.6 and 5.1.0, if a user is granted the `admin:users` scope, they may escalate their own privileges by making themselves a full admin user. The impact is relatively small in that `admin:users` is already an extremely privileged scope only granted to trusted users.\nIn effect, `admin:users` is equivalent to `admin=True`, which is not intended. Note that the change here only prevents escalation to the built-in JupyterHub admin role that has unrestricted permissions. It does not prevent users with e.g. `groups` permissions from granting themselves or other users permissions via group membership, which is intentional. Versions 4.1.6 and 5.1.0 fix this issue.","ecosystems":["Bitnami","PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"JupyterHub has a privilege escalation vulnerability with the `admin:users` scope","id":"CVE-2024-41942","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"privilege_escalation","year":"2024"},"n_packages":6,"n_references":3,"next":{"headline":"I, Librarian Stored XSS vulnerability in Item Summary","id":"CVE-2024-41943"},"packages":[{"ecosystem":"Bitnami","fixed":["4.1.6","5.1.0"],"introduced":["0","5.0.0"],"last_affected":[],"package":"jupyterhub","purl":"pkg:bitnami/jupyterhub","source":"BIT-jupyterhub-2024-41942"},{"ecosystem":"PyPI","fixed":["4.1.6"],"introduced":["0"],"last_affected":[],"package":"jupyterhub","purl":null,"source":"GHSA-9x4q-3gxw-849f"},{"ecosystem":"PyPI","fixed":["4.1.6"],"introduced":["0"],"last_affected":[],"package":"jupyterhub","purl":"pkg:pypi/jupyterhub","source":"GHSA-9x4q-3gxw-849f"},{"ecosystem":"PyPI","fixed":["4.1.6"],"introduced":["0"],"last_affected":[],"package":"jupyterhub","purl":"pkg:pypi/jupyterhub","source":"PYSEC-2024-200"},{"ecosystem":"PyPI","fixed":["5.1.0"],"introduced":["5.0.0"],"last_affected":[],"package":"jupyterhub","purl":null,"source":"GHSA-9x4q-3gxw-849f"},{"ecosystem":"PyPI","fixed":["5.1.0"],"introduced":["5.0.0"],"last_affected":[],"package":"jupyterhub","purl":"pkg:pypi/jupyterhub","source":"GHSA-9x4q-3gxw-849f"}],"prev":{"headline":"Missing authorization in SINEC NMS","id":"CVE-2024-41941"},"products":["jupyterhub"],"published":"2024-08-08","related":[{"cvss_score":8.1,"headline":"XSS in JupyterHub via Self-XSS leveraged by Cookie Tossing","id":"CVE-2024-28233","kev_date_added":null,"published":"2024-03-27"},{"cvss_score":6.1,"headline":"Open Redirect vulnerability in jupyterhub and notebook","id":"CVE-2019-10255","kev_date_added":null,"published":"2019-03-28"},{"cvss_score":5.4,"headline":"JupyterHub: Cross-origin form POSTs bypass XSRF","id":"CVE-2026-40864","kev_date_added":null,"published":"2026-05-22"},{"cvss_score":5.1,"headline":"JupyterHub has an Open Redirect Vulnerability","id":"CVE-2026-33709","kev_date_added":null,"published":"2026-04-03"},{"cvss_score":4.5,"headline":"Cross-Site Request Forgery in JupyterHub","id":"CVE-2020-36191","kev_date_added":null,"published":"2021-01-13"},{"cvss_score":3.5,"headline":"incomplete logout in JupyterHub","id":"CVE-2021-41247","kev_date_added":null,"published":"2021-11-04"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-08","vendors":["jupyterhub"]},"summary":"Users with admin:users scope can escalate to full admin privileges in JupyterHub, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2024-41942/"}