# CVE-2024-41947: XWiki Platform XSS through conflict resolution

> An attacker can execute JavaScript on other users' browsers by triggering a page edit conflict, compromising the XWiki installation's confidentiality and integrity.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Jul 2024
- **Updated:** 13 Aug 2024
- **Also known as:** GHSA-692v-783f-mg8x

## What is CVE-2024-41947?

CVE-2024-41947 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 31 Jul 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. By creating a conflict when another user with more rights is currently editing a page, it is possible to execute JavaScript snippets on the side of the other user, which compromises the confidentiality, integrity and availability of the whole XWiki installation. This has been patched in XWiki 15.10.8 and 16.3.0RC1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page)

## Which versions are affected by CVE-2024-41947?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-web-templates. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 11.8-rc-1 | 15.10.8 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 11.8-rc-1 | 15.10.8 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 16.0.0-rc-1 | 16.3.0-rc-1 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 16.0.0-rc-1 | 16.3.0-rc-1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2024-41947?

Upgrade org.xwiki.platform:xwiki-platform-web-templates to a fixed version for your release line: 15.10.8 or 16.3.0-rc-1.

## Is CVE-2024-41947 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-41947 exists.

Public exploit code:

- OpenCMS 17.0 - Stored Cross Site Scripting (XSS) (exploitdb)

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-41947 and fix it if it is affected.

What it is: CVE-2024-41947 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 31 Jul 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-41947 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 11.8-rc-1; fixed in 15.10.8
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 11.8-rc-1; fixed in 15.10.8
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 16.0.0-rc-1; fixed in 16.3.0-rc-1
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 16.0.0-rc-1; fixed in 16.3.0-rc-1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-41947/ (Markdown: https://insights.sbomify.com/CVE-2024-41947/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-41947
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-41947
- OSV: https://osv.dev/vulnerability/CVE-2024-41947

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-41947/
Summaries are generated and may contain mistakes; the official description above is the record.
