# CVE-2024-41948: biscuit-java vulnerable to public key confusion in third party block

> A malicious user can trick a third-party authority into trusting the wrong keypair, bypassing authentication checks in the biscuit-java library.

- **Severity:** Low 3.0 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2024
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-5hcj-rwm6-xmw4

## What is CVE-2024-41948?

CVE-2024-41948 is a low-severity authentication bypass vulnerability in biscuit-auth biscuit-java, published on 1 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

biscuit-java is the java implementation of Biscuit, an authentication and authorization token for microservices architectures. Third-party blocks can be generated without transferring the whole token to the third-party authority. Instead, a ThirdPartyBlock request can be sent, providing only the necessary info to generate a third-party block and to sign it, which includes the public key of the previous block (used in the signature) and the public keys part of the token symbol table (for public key interning in datalog expressions). A third-part block request forged by a malicious user can trick the third-party authority into generating datalog trusting the wrong keypair. This vulnerability is fixed in 4.0.0.

Weakness: CWE-1259 (Improper Restriction of Security Token Assignment)

## Which versions are affected by CVE-2024-41948?

2 open source packages ship an affected version, including org.biscuitsec:biscuit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.biscuitsec:biscuit` | Maven | From 3.0.0 | 4.0.0 |
| `org.biscuitsec:biscuit` | Maven | From 3.0.0 | 4.0.0 |

Products: Biscuitsec Biscuit-Java.

## How do I fix CVE-2024-41948?

Upgrade org.biscuitsec:biscuit to 4.0.0 or later.

## Is CVE-2024-41948 being exploited?

There is no known exploitation of CVE-2024-41948 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-41948 and fix it if it is affected.

What it is: CVE-2024-41948 is a low-severity authentication bypass vulnerability in biscuit-auth biscuit-java, published on 1 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-41948 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.biscuitsec:biscuit (Maven): affected from 3.0.0; fixed in 4.0.0
- org.biscuitsec:biscuit (Maven): affected from 3.0.0; fixed in 4.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-41948/ (Markdown: https://insights.sbomify.com/CVE-2024-41948/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-41948
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-41948
- OSV: https://osv.dev/vulnerability/CVE-2024-41948

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-41948/
Summaries are generated and may contain mistakes; the official description above is the record.
