CVE-2024-4195 Mattermost allows team admins to promote guests to team admins

Low 2.7 Published Updated

A team admin can improperly promote guests to team admin status due to insufficient role validation, allowing unauthorized privilege escalation.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-4195?

CVE-2024-4195 is a low-severity vulnerability in Mattermost Mattermost Server, published on 26 Apr 2024. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Mattermost versions 9.6.0, 9.5.x before 9.5.3, and 8.1.x before 8.1.12 fail to fully validate role changes, which allows an attacker authenticated as a team admin to promote guests to team admins via crafted HTTP requests.

Weakness: CWE-284

Which versions are affected by CVE-2024-4195?

5 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost-server GoFrom 8.1.08.1.12
github.com/mattermost/mattermost-server GoFrom 8.1.08.1.12
github.com/mattermost/mattermost-server GoFrom 8.1.0+incompatible8.1.12+incompatible, 9.5.3+incompatible
github.com/mattermost/mattermost-server GoFrom 9.5.09.5.3
github.com/mattermost/mattermost-server GoFrom 9.5.09.5.3

Products include Mattermost Mattermost Server.

How do I fix CVE-2024-4195?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 8.1.12, 8.1.12+incompatible, 9.5.3+incompatible or 9.5.3.

Is CVE-2024-4195 being exploited?

There is no known exploitation of CVE-2024-4195 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as GHSA-5fh7-7mw7-mmx5, GO-2024-2793.

Is CVE-2024-4195 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free