{"answers":{"affected":"3 open source packages ship an affected version, including haystack-ai.","exploited":"There is no known exploitation of CVE-2024-41950 in the wild and no public exploit code.","fix":"Upgrade haystack-ai to 2.3.1 or later.","what":"CVE-2024-41950 is a high-severity code injection vulnerability in deepset-ai haystack, published on 31 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-41950 and fix it if it is affected.\n\nWhat it is: CVE-2024-41950 is a high-severity code injection vulnerability in deepset-ai haystack, published on 31 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-41950 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- haystack-ai (PyPI): affected all versions; fixed in 2.3.1\n- haystack-ai (PyPI): affected all versions; fixed in 2.3.1\n- haystack-ai (PyPI): affected all versions; fixed in 2.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-41950/ (Markdown: https://insights.sbomify.com/CVE-2024-41950/index.md)","id":"CVE-2024-41950","markdown":"https://insights.sbomify.com/CVE-2024-41950/index.md","name":"CVE-2024-41950","record":{"aliases":["GHSA-hx9v-6r9f-w677","PYSEC-2026-1447"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"LLM framework library","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary code by injecting malicious Jinja2 templates into Haystack pipelines, requiring an upgrade to the latest version.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-1336","name":"Improper Neutralization of Special Elements Used in a Template Engine"}],"description":"Haystack is an end-to-end LLM framework that allows you to build applications powered by LLMs, Transformer models, vector search and more. Haystack clients that let their users create and run Pipelines from scratch are vulnerable to remote code executions. Certain Components in Haystack use Jinja2 templates, if anyone can create and render that template on the client machine they run any code. The vulnerability has been fixed with Haystack `2.3.1`.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Insecure Jinja2 templates rendered in Haystack Components can lead to RCE","id":"CVE-2024-41950","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":3,"n_references":6,"next":{"headline":"PheonixAppAPI has visible Encoding Maps","id":"CVE-2024-41951"},"packages":[{"ecosystem":"PyPI","fixed":["2.3.1"],"introduced":["0"],"last_affected":[],"package":"haystack-ai","purl":null,"source":"GHSA-hx9v-6r9f-w677"},{"ecosystem":"PyPI","fixed":["2.3.1"],"introduced":["0"],"last_affected":[],"package":"haystack-ai","purl":"pkg:pypi/haystack-ai","source":"GHSA-hx9v-6r9f-w677"},{"ecosystem":"PyPI","fixed":["2.3.1"],"introduced":["0"],"last_affected":[],"package":"haystack-ai","purl":"pkg:pypi/haystack-ai","source":"PYSEC-2026-1447"}],"prev":{"headline":"biscuit-rust vulnerable to public key confusion in third party block","id":"CVE-2024-41949"},"products":["haystack"],"published":"2024-07-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-07-31","vendors":["deepset-ai"]},"summary":"Attackers can execute arbitrary code by injecting malicious Jinja2 templates into Haystack pipelines, requiring an upgrade to the latest version.","url":"https://insights.sbomify.com/CVE-2024-41950/"}