# CVE-2024-41950: Insecure Jinja2 templates rendered in Haystack Components can lead to RCE

> Attackers can execute arbitrary code by injecting malicious Jinja2 templates into Haystack pipelines, requiring an upgrade to the latest version.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Jul 2024
- **Updated:** 31 Jul 2024
- **Also known as:** GHSA-hx9v-6r9f-w677, PYSEC-2026-1447

## What is CVE-2024-41950?

CVE-2024-41950 is a high-severity code injection vulnerability in deepset-ai haystack, published on 31 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Haystack is an end-to-end LLM framework that allows you to build applications powered by LLMs, Transformer models, vector search and more. Haystack clients that let their users create and run Pipelines from scratch are vulnerable to remote code executions. Certain Components in Haystack use Jinja2 templates, if anyone can create and render that template on the client machine they run any code. The vulnerability has been fixed with Haystack `2.3.1`.

Weakness: CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2024-41950?

3 open source packages ship an affected version, including haystack-ai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `haystack-ai` | PyPI | All versions | 2.3.1 |
| `haystack-ai` | PyPI | All versions | 2.3.1 |
| `haystack-ai` | PyPI | All versions | 2.3.1 |

## How do I fix CVE-2024-41950?

Upgrade haystack-ai to 2.3.1 or later.

## Is CVE-2024-41950 being exploited?

There is no known exploitation of CVE-2024-41950 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-41950 and fix it if it is affected.

What it is: CVE-2024-41950 is a high-severity code injection vulnerability in deepset-ai haystack, published on 31 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-41950 in the wild and no public exploit code.

Affected packages and fixed versions:
- haystack-ai (PyPI): affected all versions; fixed in 2.3.1
- haystack-ai (PyPI): affected all versions; fixed in 2.3.1
- haystack-ai (PyPI): affected all versions; fixed in 2.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-41950/ (Markdown: https://insights.sbomify.com/CVE-2024-41950/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-41950
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-41950
- OSV: https://osv.dev/vulnerability/CVE-2024-41950

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-41950/
Summaries are generated and may contain mistakes; the official description above is the record.
